680i issues - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 10-22-2008, 04:06 PM   #1 (permalink)
Monster Techie
 
Join Date: May 2008
Location: San Diego
Posts: 1,958
Send a message via AIM to Burn
Default 680i issues

My 680i recently died, i get "--" post codes on startup, have tried multiple things and still nothing. My question is: Evga accepted my RMA request, but i don't have the original receipt from Frys, could i go to frys and get one printed for me?
__________________

__________________
Burn is offline  
Old 10-22-2008, 04:50 PM   #2 (permalink)
I poop on the rug
 
NosBoost300's Avatar
 
Join Date: Nov 2005
Location: Bellflower, CA
Posts: 10,217
Default Re: 680i issues

you might be able to get one from fry's.. i've never rma'd anything in my life before so i don't know...

all you should need is ur box with the upc or whatever and register it under your name.. if i remember right
__________________

__________________
Current Build:
Intel 8700k | 16GB G.skill Trident Z | Z370 Gigabyte Auros Gaming Extreme |
Asus GTX1080 Strix | Corsair H100i V2 | Corsair 750D | Corsair RM850X
NosBoost300 is offline  
Old 10-22-2008, 04:52 PM   #3 (permalink)
Junior Techie
 
Join Date: Sep 2008
Posts: 64
Default Re: 680i issues

Yeah I'm sure you can call them up and ask them to look in their records for your purchase. They should be able to fax you the receipt. Or yeah, pick one up.
__________________
Inserity is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PS3 2.42 Firmware Issues? Osiris Sony Playstation 4 08-04-2008 02:15 PM
680i vs 780i OC stability Issues. RicoDirenzo Overclocking and Modding 0 05-23-2008 11:18 AM
Issues issues issues. Vista-64bit. 9600GT's in SLI. 4GB Vista problems. Oy Vey. TheOtis Hardware Repairs and Troubleshooting 2 03-24-2008 11:59 AM
Memory issues Eternal46845 Hardware Repairs and Troubleshooting 1 02-12-2008 07:37 AM
Gigafast Router - Connectivity Issues When Running Torrents - Advanced Problem throthedice Computer Networking and Internet Hardware 1 09-27-2007 09:12 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:49 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.