500GB External Fantom NOT RECOGNIZING! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 12-10-2008, 08:15 AM   #1 (permalink)
Newb Techie
 
Join Date: Dec 2008
Posts: 6
Default 500GB External Fantom NOT RECOGNIZING!

I bought a 500GB Fantom Disk Drive (external) from Comp USA for around 90 bucks a couple of months ago. Since then I've used it an amount and steal all of my friends music whenever I am over at their place with my drive. I had taken it off and let it sit for about two weeks and went to plug it in the other day and it gave me the hardware install wizard and would not show in My Computer or Disk Manager. After more searching around I found out that it actually DID display in disk manager but it displayed in the USB Device section with a yellow "!" Any ideas as to how I can get it working?
__________________

Dire Marksman is offline  
Old 12-10-2008, 12:52 PM   #2 (permalink)

Triforcer
 
Baez's Avatar
 
Join Date: Sep 2005
Location: Toronto, Canada
Posts: 6,987
Default Re: 500GB External Fantom NOT RECOGNIZING!

It could either be the hard disk itself or just a driver problem. Try another USB port if you haven't already. If you have then click on the drive in disk management and see what Windows says the problem is.
__________________

__________________


Baez is offline  
Old 12-10-2008, 03:53 PM   #3 (permalink)
Newb Techie
 
Join Date: Dec 2008
Posts: 6
Default Re: 500GB External Fantom NOT RECOGNIZING!

I have tried many USB ports and I know the the cable is functioning because the cable worked when I tested it on my printer and the printer worked just fine.

When I plug the Drive in it brings up a "Found New Hardware" installation wizard but Fantom Disk Drives claims that with Windows XP you do not need any firmware or drivers for the drive itself to function.

In the Device Manager console it is listed under "Other Devices" and it tells me there is a USB Device with a yellow "!" but I'm not sure what this in fact means.

When right click> properties, it tells me "This device is not configured correctly. (Code 1)"
Dire Marksman is offline  
Old 12-11-2008, 06:09 AM   #4 (permalink)

Triforcer
 
Baez's Avatar
 
Join Date: Sep 2005
Location: Toronto, Canada
Posts: 6,987
Default Re: 500GB External Fantom NOT RECOGNIZING!

Go into Device Manager and right click on your drive and go into properties again. There should be a Driver tab at the top of the Window. Click on that and choose Uninstall Driver... If the uninstall option is unavailable you should be able to find the driver on Fantom's site and reinstall it manually.
__________________


Baez is offline  
Old 12-11-2008, 07:47 AM   #5 (permalink)
Newb Techie
 
Join Date: Dec 2008
Posts: 6
Default Re: 500GB External Fantom NOT RECOGNIZING!

The problem with that is that Fatom does not provide drivers, their drives should work with any XP and Vista PC but it obviously is failing at that attempt.
Dire Marksman is offline  
Old 12-11-2008, 09:13 PM   #6 (permalink)

Triforcer
 
Baez's Avatar
 
Join Date: Sep 2005
Location: Toronto, Canada
Posts: 6,987
Default Re: 500GB External Fantom NOT RECOGNIZING!

It should just use the generic hard drive drivers then. Did you try what I suggested about uninstalling the drivers?
__________________


Baez is offline  
Old 12-12-2008, 06:47 AM   #7 (permalink)
Newb Techie
 
Join Date: Dec 2008
Posts: 6
Default Re: 500GB External Fantom NOT RECOGNIZING!

I did try uninstalling the drivers and XP let me do it even though it had no drivers to uninstall. I couldn't recognize the drive at all and so after I rebooted it connects again, prompts me with a hardware wizard and shows up in again in Other Devices > USB Device in the Manager with a Yellow "!"
Dire Marksman is offline  
Old 12-12-2008, 12:51 PM   #8 (permalink)

Triforcer
 
Baez's Avatar
 
Join Date: Sep 2005
Location: Toronto, Canada
Posts: 6,987
Default Re: 500GB External Fantom NOT RECOGNIZING!

Hmm could be the actual enclosure that has gone. You can remove the enclosure from the drive and test it to see.
__________________


Baez is offline  
Old 12-12-2008, 05:08 PM   #9 (permalink)
Newb Techie
 
Join Date: Dec 2008
Posts: 6
Default Re: 500GB External Fantom NOT RECOGNIZING!

I would rather not do that but its something that I could try. The drive is also eSATA capable and I am ordering one which is currently in Kansas so I am planning on waiting until then to see if that will work.

Anyone have any other suggestions?
__________________

Dire Marksman is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Booting Windows XP From An External Drive Osiris Apple and Mac 0 09-11-2008 09:23 AM
Multi-Disk external hard drives. jfried System Upgrades 0 05-22-2008 07:41 PM
WD 500gb my book external hdd jesspren6 Hardware Repairs and Troubleshooting 2 01-24-2008 08:06 PM
Acces Denied on My Cloned External Drive How do I gain Access. imergeandsee Hardware Repairs and Troubleshooting 3 01-18-2008 12:25 PM
External Hard Drive troubles Grahto22 Hardware Repairs and Troubleshooting 2 09-23-2007 08:03 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:49 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.