RMA'ing my Motherboard - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 04-15-2007, 03:24 PM   #1 (permalink)
Junior Techie
 
Join Date: Oct 2006
Posts: 40
Default RMA'ing my Motherboard

OK, so my GIGABYTE GA-965P-DS3 is messed up, so I'm RMA'ing it. The problem is I can't seem to find the small plastic socket cover. Is that a requirement for newegg motherboard RMA's. Will they refuse the RMA, or charge me something extra or what?
__________________

megaerik00 is offline  
Old 04-15-2007, 03:38 PM   #2 (permalink)
Monster Techie
 
Ridlyn's Avatar
 
Join Date: May 2005
Posts: 1,920
Default Re: RMA'ing my Motherboard

I don't know if newegg requires it. But an RMA to Gigabyte requires it. I would try and ask newegg first before you RMA it.
__________________
Quote:
Originally Posted by Sylus View Post
Could have been worse, you could have been raped by a clown.
Ridlyn is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
motherboard temp problems maybe? plumber4578 New Systems | Building and Buying 9 04-09-2007 08:45 PM
motherboard is HOT (i think) Nick Hardware Repairs and Troubleshooting 8 03-27-2007 01:47 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.