Quick help PLEASE! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Closed Thread
Thread Tools Display Modes
Old 04-02-2006, 06:51 PM   #1 (permalink)
True Techie
Join Date: Feb 2006
Posts: 104
Default Quick help PLEASE!

im installing a Blue Orb II fan on my A8N32-Sli motherboard with a AMD Athlon 64 FX 60 processor, but the thing is the screws wont go all way down. Its like if the processor was too high and wouldnt let it go down. PLZ help, do i have to push it down hard or what do i do ><?

ChibChombo is offline  
Old 04-02-2006, 07:42 PM   #2 (permalink)
Join Date: Feb 2006
Posts: 2,130

well if its tight and doesnt move around, not even the slightest bit, its fine i think.
john3 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:35 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.