Quick help needed... - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Closed Thread
Thread Tools Display Modes
Old 08-29-2007, 10:51 AM   #1 (permalink)
Junior Techie
magezzz's Avatar
Join Date: Dec 2006
Location: Canada
Posts: 95
Default Quick help needed...

While installing the cpu fan (intel stock), the 2 right handed "legs" clicked into the motherboard (Gigabyte GA-P35C-DS3R) with the white plastic on the other side and a black prong in the middle. However on the 2 left sides, the white part went threw, but not the 2 black prongs...I tried pushing with reasonable force to get the black prongs in, and nothing happened...what do I do?

Seagate 320GB
Corsair HX 620W
eVGA 8800GTS 320MB
Gigabyte GA-P35C-DS3R
CoolerMaster Centurion 5
OCZ 2x1GB Revision 2 PC6400 800Mhz
magezzz is offline  
Old 08-29-2007, 09:12 PM   #2 (permalink)
Master Techie
Join Date: Jul 2007
Location: San Jose, California
Posts: 2,456
Send a message via AIM to phucng_10 Send a message via Yahoo to phucng_10
Default Re: Quick help needed...

Have to put a bit of pressure onto those pins.

You can watch this Video from YouTube and see how they install the HSF.

There's a crap load of talking, so you'll have to wait a bit.

|phucng_10's WM|
phucng_10 is offline  
Old 08-30-2007, 07:33 AM   #3 (permalink)
Master Techie
baron5's Avatar
Join Date: Feb 2007
Location: Australia
Posts: 2,984
Default Re: Quick help needed...

omg. i has exact same prob 1 day ago. take out he mobo! sit it down on an anit static bag and hold one side of motherboard otherwise ull bend it too much with the force u need. use something pong and skinny to push all the pong out then try clip em 1 at time but once u done first one go diagonal to the second.
<<<Please give me Rep if I have helped you<<<

I7 930 @ 4GHz : Noctua D-14
Gigabyte X58A-UD7 : Asus GTX 480
G.Skill Trident 1600MHz 6-8-7-18 : Samsung F3 1TB
OCZ Vertex 2 50GB : Silverstone RV02 Case
Silverstone Strider Plus 1Kw : Sony DRU-870s Optical
Samsung P2350 Monito

baron5 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Saving Quick Launch Icons cliffhucker Microsoft Windows and Software 6 06-25-2007 06:37 PM
Some Applications Arent Able to Connect to a Remote Server as Needed quazia83 Computer Networking and Internet Hardware 3 06-25-2007 12:47 PM
I cannot post a quick reply siddanth3 New Systems | Building and Buying 1 05-25-2007 12:07 AM
Quick question sailpog New Systems | Building and Buying 4 04-11-2007 10:38 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:20 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.