PSU issue! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 09-03-2007, 05:58 AM   #1 (permalink)
Junior Techie
 
Join Date: Dec 2004
Posts: 52
Default PSU issue!

I just bought my PC
E6750
P35-DS3
RAM 2GB GSKILL 4-4-4-13
250GBx2 SEAGATE HDD
X2900XT VGA

and i am using PSU 650W COOLER MASTER REAL POWER DUO
my friends say it can't run my PC system because cooler master has such less quality PSU than other brand....and it has only 6 PIN -PCI so i cant run ATI overdrive on CAT 7.8
Any suggestion dat should i buy a new PSU? or just keep the same, however i can return to the shop with the PSU and probably i can add $50 to obtain the better on? should i or shouldnt i?
thanks
__________________

anthegreat is offline  
Old 09-03-2007, 08:44 AM   #2 (permalink)
Master Techie
 
baron5's Avatar
 
Join Date: Feb 2007
Location: Australia
Posts: 2,984
Default Re: PSU issue!

should. but still i would have thought it should still run your rig. a 650w psu should prob have about 36amps and im guessing its a dual rail coz of the name. so should be 18amps on each rail. have a look at the specs to see how many amps it has on the 12v rails.
__________________
<<<Please give me Rep if I have helped you<<<

I7 930 @ 4GHz : Noctua D-14
Gigabyte X58A-UD7 : Asus GTX 480
G.Skill Trident 1600MHz 6-8-7-18 : Samsung F3 1TB
OCZ Vertex 2 50GB : Silverstone RV02 Case
Silverstone Strider Plus 1Kw : Sony DRU-870s Optical
Samsung P2350 Monito
r

baron5 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vista, Lost Planet, and 8800GTS issue. TheOtis Hardware Repairs and Troubleshooting 3 07-30-2007 05:15 PM
Issue with start up. Peter.Cort Hardware Repairs and Troubleshooting 5 07-30-2007 12:43 PM
Sound Issue Dieo Hardware Repairs and Troubleshooting 11 07-13-2007 03:19 PM
TV Card issue AntonOle Hardware Repairs and Troubleshooting 1 05-17-2007 08:31 AM
Weird IE7 Issue reubix Microsoft Windows and Software 1 05-02-2007 02:54 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:23 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.