problem with display - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 11-15-2009, 06:35 PM   #1 (permalink)
Newb Techie
 
Join Date: Nov 2009
Location: Freeport Il
Posts: 4
Default problem with display

just got a new mobo, gc, cpu, ram, psu cant get any thing to display on the moniter and the computer wont turn off once it is on... i have tried swapping the old gc back into the mobo but nothing happens still everything is supported and everything is hooked up correctly
Drenfest is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Windows Explorer Has Encountered a Problem blah blah" AND EVERYTHING ELSE bandana159 Microsoft Windows and Software 4 09-08-2009 01:13 PM
Graphics Card Display problem. Sketzii Hardware Repairs and Troubleshooting 8 09-03-2009 04:36 PM
Display Problem spike1 Hardware Repairs and Troubleshooting 8 07-22-2008 06:03 PM
Built new PC, on 2nd Mobo, still no video display! HELP!!! imconfused Hardware Repairs and Troubleshooting 22 11-29-2007 10:40 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.