Problem - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 12-17-2005, 08:33 AM   #1 (permalink)
Junior Techie
 
Join Date: Oct 2005
Posts: 52
Default Problem

Hey All,

recently upgraded PC and now certain game (king kong and farcry so far that Ive tested) run terriblely. King kong is extremly stuttered, low framerate and unplayable. Farcry has unbleiveably bad shadings making shadows look pitch black and square.

Battlefield 2 Spec ops, however, runs flawlessly. Not a glitch.

I have updated my graphics card drivers, mobo drivers, bios, installed all latest direct x, windows updates. King king has improved slightly, but still unplayable. (Extreme bad fps, glitches, some ai looks to be in fast forward mode) Farcy no improvement, still bad shadings on high. Low shadings helps but texture still looks poor. Have updated all the games with patches except king kong which hasnt got 1 yet.

My new specs are:

Asus A8N Sli Premium
AMD X2 4800+
2 x MSI Geforce 7800GTX Sli 256 mb
2048 DDRSD RAM (Kingstone)
X-Fi FPS Edition


Any ideas why it should do this? My old specs (AMD 3000+, ATI 800XT MSI K8N NEO) ran all these great.

Thnaks in advance, any help would be great.
TermyBGL is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:21 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.