Parts......good Enough???? - Page 3 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 07-12-2007, 05:59 PM   #21 (permalink)
Retired.
 
peterhuang913's Avatar
 
Join Date: Dec 2005
Location: Los Angeles, California
Posts: 8,076
Send a message via AIM to peterhuang913
Default Re: Parts......good Enough????

dont delete, all posts are welcome, even repeats =D
__________________

__________________


My computer uses 1.5A-load, .8A-idle, .65A-standby, .05A-turned off on 125V.
"The spaces between your fingers were created so that another's could fill them in."
Quote:
Originally Posted by Norcent View Post
I need to stop using the internet.
peterhuang913 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
A good fan controller? MildTweeker Overclocking and Modding 11 09-04-2007 06:27 AM
Will an 8800GTS be enough for a good gaming system. Saint71 New Systems | Building and Buying 18 07-12-2007 12:46 PM
khan008 here is a run down of what is good and bad with your build saltynay New Systems | Building and Buying 190 05-22-2007 04:56 PM
Good Used Parts - Old Stuff Fastvan67 Buy/Sell/Trade and Hot Deals 0 04-29-2007 12:22 AM
Good Webcam? SiZcO Computer Audio and Multimedia 2 04-07-2007 02:21 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:20 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.