Open Box motherboard experience.... - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 10-17-2006, 10:19 AM   #1 (permalink)
Ultra Techie
 
UA_Iron's Avatar
 
Join Date: Aug 2005
Posts: 857
Default Open Box motherboard experience....

Kind of a hardware topic - hope its not in the wrong forum.

I have purchased a couple biostar motherboards open box cause their micro-atx Tforce AMD mobo's are awesome for general builds in my opinion.

The thing that always bugged me was the lack of the I/O shield that comes with the mobos. What does newegg do with these? Seriously, you cant return mobos without all the necessary components - does newegg just toss everything besides the mobo and driver CD?


So yesterday I emailed biostar where I could get an I/O shield - that very same day they emailed me back. Today they are shipping out 3 I/O shields free of charge

Just thought I'd share my experience with open box mobos. Try to hit up the manufacturer for missing parts - they might respond in the same way biostar did.


Cliff notes: Open box mobo, no I/O Shield, emailed biostar, they sending me 3.
__________________

UA_Iron is offline  
Old 10-17-2006, 10:42 AM   #2 (permalink)
There and Back again
 
Nukem's Avatar
 
Join Date: Jan 2005
Location: Chattanooga, TN
Posts: 4,402
Default

That's the bad part about open box. If Newegg receives it back with missing parts... they don't really care. For the most part it'll get sold anyway... I've bought open box and had it happen to me as well... I even got a bad board once... they accepted it back, but it's still a pain in the @55
__________________

__________________



Dell 4K S2817Q / Logitech Z-680 / Func MS3 Mouse / Corsair K70 LUX rgb
NZXT Source 530 / i5-7600K / Corsair H100i v2 / ASRock Z270 Extreme4
SM951 M2 256GB / 850 evo 1TB / Seagate 2TB / WD 2TB
2x16GB Vengeance LPX DDR4 3000 / evga Classified GTX 980 ti / Seasonic M12II 850W

Nukem is offline  
Old 10-17-2006, 07:40 PM   #3 (permalink)
j12
Monster Techie
 
j12's Avatar
 
Join Date: Jun 2006
Posts: 1,133
Default

maybe i'm just dumb, whats an I/O shield?
__________________

Laptop:
MacBook 2.2GHz Santa Rosa | 120GB HDD | 4GB ram
Desktop:
Intel C2D E6300 @ 3.2GHz | 4GB ram | 880GB total HDD space | Gigabyte P965-DS3 | eVGA 8800GTS 640mb | Corsair HX 520 | Audigy 2 ZS platnium | Antec 900
j12 is offline  
Old 10-17-2006, 08:06 PM   #4 (permalink)
003
Wizard Techie
 
Join Date: May 2005
Posts: 3,312
Default

That metal rectangle you install on the case that all the motherboard sockets fit through.
__________________
so, umm, err yeah
003 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.