Old laptop please help - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Closed Thread
Thread Tools Display Modes
Old 12-27-2009, 04:49 PM   #1 (permalink)
Newb Techie
Join Date: Apr 2007
Posts: 8
Send a message via ICQ to jskd82 Send a message via Yahoo to jskd82
Default Old laptop please help

I am not sure what is causing me to lag so badly in world of warcraft so I'll give you some specs. First off, I am playing on an old laptop, the specs are....Intel Pentium M processor 1.60GHZ, 1.25GB RAM, ATI Mobility Radeon X300 video card. So yes it is a crappy system, but it seems to run WoW smooth on low settings. Now the other thing is that I have my cell phone tethered to my laptop for the internet connection. I did a speed test and it ranged from 0.70 download and 0.20 upload to 2.4 0 download and 0.50 upload. I would think that those speeds would be enough to run WoW without lag, but for some reason I get huge lag while in game, even when in areas with minimal traffic/textures. The lag that I am experiencing is not being able to cast spells or anything. The game isn't jumpy at all and runs smooth. Could it be possible that my laptop's old hardware is causing a bandwidth type of lag? Sorry for the long post TIA. I should also add then when browsing the internet or downloading files they download fast like DSL speed.

jskd82 is offline  
Old 12-29-2009, 05:32 PM   #2 (permalink)
Junior Techie
Join Date: Jun 2009
Posts: 82
Default Re: Old laptop please help

Your being held back by your tether, you'll need a faster internet connection. My brother has a similar laptop and can run WoW at 40fps on mid-low settings.

VishKapish is offline  
Old 12-29-2009, 09:22 PM   #3 (permalink)
True Techie
Join Date: Dec 2007
Posts: 156
Default Re: Old laptop please help

I agree with the above, even though it shows those download speeds you are probably being "lagged" by the latency (the quality of your connection with the server).
Core-i7 930
Asus P6X58D Premium
6gb Mushkin DDR3
OCZ-Vertex SSD
Q6600 (G0) @ Stock
Nvidia 8800GT x2 SLI @ Stock
4GB DDR2-PC6400 @ Stock
500GB Sata + 1TB
Evga 780i
masteroc is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Laptop advice - From someone who has one Puressence Laptops and Notebooks 9 03-20-2009 03:27 PM
Processor and graphics question, for buying laptop? Joecoolwashere Laptops and Notebooks 8 02-10-2009 01:07 PM
Teacher + School >>> Laptop + Home - Connectivity Issues. Jayce Computer Networking and Internet Hardware 12 08-28-2008 08:24 PM
Laptop PSU Problem spiking CPU billythefish Laptops and Notebooks 2 08-25-2008 01:52 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:35 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.