Newegg Processing Problem? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 04-07-2009, 12:09 AM   #1 (permalink)
Junior Techie
 
Join Date: Apr 2009
Posts: 54
Default Newegg Processing Problem?

Howdy,

Last Saturday, I ordered all the parts for an upcoming build through Newegg. I had to split up the purchase into 4 bundles for several boring reasons, and 3/4 orders have been shipped according to the Order Status page. The first 2 orders were actually sent out on Sunday, which surprised me. The largest and most expensive order, which includes 7 items, is still stuck on "Submitted" even though it was sent only a few minutes after the third order (which was successfully shipped at about noon today). Since this last order has been stuck on "Submitted" since mid-Saturday, is it worth calling in about? I'm quite excited about getting these parts and it seems rather strange that all the other bundles went through so quickly.

Thanks,
M

P.S.
I've also noticed that, even though the last order hasn't been "Shipped," the parts are divided into two groups, one "shipped out of NJ" and the other "shipped out of CA." In my previous orders, I didn't get the "shipped out of" details until I got the UPS tracking number. Is this unusual?
__________________

mliraved is offline  
Old 04-07-2009, 12:41 AM   #2 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,516
Default Re: Newegg Processing Problem?

Call them and find out. My stuff is coming in fine; I ordered last week (thurs or fri..somethin like that) and I'm getting my stuff right on time.
__________________

__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline  
Old 04-07-2009, 01:12 AM   #3 (permalink)
AKA ComatoseClown
 
H4x3r's Avatar
 
Join Date: Dec 2004
Posts: 1,526
Send a message via AIM to H4x3r Send a message via MSN to H4x3r
Default Re: Newegg Processing Problem?

Quote:
Originally Posted by carnageX View Post
Call them and find out. My stuff is coming in fine; I ordered last week (thurs or fri..somethin like that) and I'm getting my stuff right on time.
I would do this as well, considering i ordered yesterday and it shipped out today.
__________________
H4x3r is offline  
Old 04-07-2009, 04:43 AM   #4 (permalink)
Banned
 
Join Date: Dec 2008
Posts: 326
Default Re: Newegg Processing Problem?

They may be waiting for a part to arrive
newbiebuilderguy is offline  
Old 04-07-2009, 11:18 AM   #5 (permalink)
Junior Techie
 
Join Date: Apr 2009
Posts: 54
Default Re: Newegg Processing Problem?

Address problem. Chances are I gave the wrong telephone for the address since we have two lines. Great, I get to call the credit card company!

Edit: Newegg's fraud prevention measures are over the top. I just called them and they're demanding I call the credit card company again to authorize a shipping address (apparently clearing a shipment to NY state wasn't enough). On top of that, they demand I also authorize the shipping address' phone number with my credit card company. It's beyond inconvenient.
mliraved is offline  
Old 04-07-2009, 11:43 AM   #6 (permalink)
Grandfather of Techist

\_(ツ)_/
 
Trotter's Avatar
 
Join Date: Jan 2005
Location: The South
Posts: 31,307
Default Re: Newegg Processing Problem?

Better than them not having it. Yes, it is a pain, but they want to make sure that you are who they say you are and not someone trying to rip you off.
__________________

__________________


My Rig: SABLE
Antec 300 Illusion / Antec EarthWatts EA650 650W / ASUS GeForce GTX 960 GTX960-DC2OC-2GD5
AMD FX 8320 x8 Black Edition / Gelid Tranquillo / MSI 970A-G43
Sandisk Ultra Plus 128GB / Samsung 840 120GB / WD Black 750GB / WD Green 1TB
2x4GB DDR3 1600 - 2x2GB DDR3 1600
Win10 Ent 64-bit - Mionix Naos 7000 Mouse - CM Storm QuickFire Rapid Mech Keyboard


R.I.P. Danny L. Trotter ... 14 Nov 1945 - 4 Sept 2009
Trotter is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tech-Forums Recommended PC Components v2.0 Puddle Jumper New Systems | Building and Buying 76 07-27-2009 02:36 AM
Problem installing software in windows xp pro imagesmith Microsoft Windows and Software 3 02-20-2008 02:46 PM
Odd sound problem. VERY odd. Isilwen Computer Audio and Multimedia 3 08-04-2007 09:08 PM
Serious computer problem. HeeRoMaKi Hardware Repairs and Troubleshooting 71 07-28-2007 11:42 PM
newegg problem (double order) bmxfreakrider Off Topic Discussion 17 07-13-2007 02:23 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:24 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.