New System Tell me what you think - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 03-24-2008, 12:14 AM   #11 (permalink)
M.C. Etcher
 
Grievearz's Avatar
 
Join Date: Sep 2007
Location: Gainesville FL
Posts: 321
Send a message via AIM to Grievearz
Default Re: New System Tell me what you think

Yes, get SATA. Some new boards don't even HAVE IDE interfaces anymore.
__________________

__________________


Maybe I'm a Lion...
Grievearz is offline  
Old 03-28-2008, 08:50 PM   #12 (permalink)
Newb Techie
 
Join Date: Jun 2007
Location: Long Island, New York
Posts: 9
Default Re: New System Tell me what you think

I just installed the same chip 4 hours ago.. I upgraded from the Core 2 Duo E6600.

Nice system and very nice timing.

BMN
__________________

bmn51 is offline  
Old 03-28-2008, 11:57 PM   #13 (permalink)
MetalHead Techie
 
Join Date: Jun 2007
Location: Minnesota
Posts: 2,912
Default Re: New System Tell me what you think

great build!
and get a longer warrenty and more performance with seagate
__________________
Proc Intel 2500k
Video XFX 6950 1Gb
Display 22'' Monitor Chemei 5ms RT, 800:1 CR
Mobo Biostar Z68A+
Mem 4 gb PNY DDR3 1600
Case afk
Sound Logitech z-5300e 5.1 + Razer Orca's + Creative Soundblaster Audigy SE
PSU Corsair 520hx
OS Windows 7 64-bit
Cooling Corsair H60 Liquid Cooling
HDD Hitachi 1Tb
Invisible is offline  
Old 03-30-2008, 03:11 PM   #14 (permalink)
Lord Techie
 
Luke's Avatar
 
Join Date: Dec 2007
Location: Fonthill, Ontario, Canada
Posts: 5,601
Send a message via AIM to Luke Send a message via MSN to Luke
Default Re: New System Tell me what you think

looks like a good build...nice ram
__________________

__________________
3770K @ 4.7 Ghz H100 Water Cooled | GTX 970 MSI Gold Edition SLI
32GB G.Skill RipJaws (Rendering/ Virtualization) | Corsair 650D | CORSAIR RM1000W w/ White Cable KIt
Samsung 850 Pro 256 GB SSD Boot | OCZ Vertex 3 240GB SSD Secondary | WD Black 1 TB | WD Green 3 TB
Server: Core i7 920 | 8GB RAM | Intel 240gb 730 SSD Boot | 3 x 2TB WD RED | Fractal R4
Luke is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Black Viper's Top tweaks for a faster PC xXxexpertxXx Overclocking and Modding 0 02-21-2008 10:04 PM
Issue with BF2 on my E510 dykzeulb PC Gaming 8 10-21-2007 04:26 PM
seagate 80gigs failing.. acuariano Hardware Repairs and Troubleshooting 27 08-27-2007 10:43 PM
AMD Athlon™ 64 X2 Dual Core Processor Utilities & Updates Osiris Overclocking and Modding 6 05-31-2007 01:41 PM
User Locked Out of Account....Its Weird Though.... qbbraveheart Computer Networking and Internet Hardware 2 05-07-2007 09:58 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.