Techist - Tech Forum

Techist - Tech Forum (http://www.techist.com/forums/)
-   New Systems | Building and Buying (http://www.techist.com/forums/f76/)
-   -   new pc doesnt show anything on the screen (http://www.techist.com/forums/f76/new-pc-doesnt-show-anything-screen-273861/)

ndy777 01-10-2015 04:40 PM

new pc doesnt show anything on the screen
 
Hey

I have built a gaming pc al the parts work but theres problem. When i turn on the it stays on for like a few seconds and turns off and turns back on by it self and then it stays on but it doesnt display anything on the screen. When its on i see all the parts running like the cpu, gpu, internal fan, cd drive but it wont show anything on the screen. I have connected it to the monitor using a hdmi cable. Can someone help me out please for why it turns off and on and show no display.

Thank you

ndy777 01-10-2015 04:41 PM

Re: new pc doesnt show anything on the screen
 
Here are the components

Z87-G43 gaming motherboard
intel core i5 4690k
msi r9 270x hawk gpu
6 gb ram- from my old system
256gb ssd- no hdd installed

600 watt crosair psu

PP Mguire 01-10-2015 06:39 PM

Re: new pc doesnt show anything on the screen
 
You plugging the monitor cable into the GPU or the motherboard?

Trotter 01-10-2015 06:48 PM

Re: new pc doesnt show anything on the screen
 
Do you have the two 6-pin power cables plugged into the card? Is the fans on the graphics card spinning up? Is it seated into the slot properly?


All times are GMT -5. The time now is 10:43 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.