need help with a video card - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Closed Thread
Thread Tools Display Modes
Old 01-30-2006, 09:29 PM   #11 (permalink)
Super Techie
Join Date: Dec 2005
Location: Massachusetts
Posts: 458

The ATI x8xx series blows. it doesnt. Theres nothing wrong with the x800, i know people who have it and it runs extremely well.

Intel E8400
Zalman 9500AT
evga 8800gt dual-slot cooler
4gig (2x2gb)g.skill ddr2 1066
gigabyte p43-ds3L
Antec sonata II mid tower
200gb Seagate HDD, 500gb Seagate HDD, 1TB Seagate HDD
bkolk is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:37 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.