Help with speakers - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Closed Thread
Thread Tools Display Modes
Old 08-10-2007, 12:15 PM   #1 (permalink)
Newb Techie
Join Date: May 2007
Posts: 17
Default Help with speakers

Hey everyone, I just got my parts and built my system and let me start off by saying that its an awesome machine.. I appreciate all the help in getting the parts together.

My problem right now however is that the sub on my Logitech Z2300 speakers will not work. My motherboard is a Gigabye p35-ds3r and for some reason when I open the sound options and I chose 2 channel speakers it has no option for a sub.

Any help would be much appreciated.

asim8787 is offline  
Old 08-10-2007, 12:21 PM   #2 (permalink)
Monster Techie
kobe24's Avatar
Join Date: May 2007
Location: Australia
Posts: 1,508
Send a message via MSN to kobe24
Default Re: Help with speakers

have u check ur connections?

3D MARK 06 ***14,063*** on vista, use to get it
p4 2.8ghz
Asus p4SD-LA
6800gs ultra
1.5gb ddr400 oem
120gb hdd

The Techies' Bible
kobe24 is offline  
Old 08-10-2007, 01:39 PM   #3 (permalink)
Newb Techie
Join Date: May 2007
Posts: 17
Default Re: Help with speakers

yes, everything is connected correctly, and i tried installing the new drivers for the motherboard but there is still no option for a 3 channel system

do i need a sound card? thats what my buddy suggested but it just doesn't seem right.
asim8787 is offline  
Old 08-10-2007, 02:02 PM   #4 (permalink)
True Techie
wrestlingnrj's Avatar
Join Date: Dec 2005
Location: Orange County, CA
Posts: 162
Send a message via AIM to wrestlingnrj
Default Re: Help with speakers

You're sub could be broken. Have you tried using another sub? Try switching the audio connections to your computer around to see if you can get any sound from it.
Intel Pent D 820 Smithfield - Intel D945PSN
eVGA 7800GT OC - 2GB OCZ Gold Series DDR2
Logitech Z-5500 *I like to feel my video games*
wrestlingnrj is offline  
Old 08-10-2007, 03:17 PM   #5 (permalink)
Newb Techie
Join Date: May 2007
Posts: 17
Default Re: Help with speakers

well i know its not broken because i had it hooked up to my laptop before i built the computer and it worked fine.

ive only had these for a couple days.
asim8787 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
speakers work in Linux but not windows :-S scottjames84 Hardware Repairs and Troubleshooting 13 07-15-2007 04:37 PM
On The Hunt: High Quality Speakers. High the:megalon Computer Audio and Multimedia 20 06-04-2007 10:48 AM
On The Hunt: High Quality Speakers. High. the:megalon New Systems | Building and Buying 1 05-17-2007 10:02 PM
Hooking speakers up via digital/5.1 Speaker placement mack Computer Audio and Multimedia 7 05-01-2007 05:41 PM
5.1 speakers to TV cable freak67 Monitors, Printers and Peripherals 3 04-04-2007 10:09 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:17 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.