help with my ram + mobo - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 06-05-2013, 05:01 PM   #1 (permalink)
Newb Techie
 
Join Date: May 2013
Location: United states
Posts: 2
Default help with my ram + mobo

hi there,
after a lot of research and thinking I bought these computer parts from newegg and put them together, now it doesnt boot up.i googled a little and figured out that my mobo supports only dual channel rams. and i bought only one stick of ram. here are my parts.

Newegg.com - ASRock B75M-DGS R2.0 LGA 1155 Intel B75 SATA 6Gb/s USB 3.0 Micro ATX Intel Motherboard
G.SKILL Ripjaws Series 4GB 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10666) Desktop Memory Model F3-10666CL9S-4GBRL - Newegg.com
Intel Core i5-3330 Ivy Bridge 3.0GHz (3.2GHz Turbo) LGA 1155 Quad-Core Desktop Processor Intel HD Graphics 2500 BX80637i53330 - Newegg.com
CORSAIR Builder Series CX500 500W ATX12V v2.3 80 PLUS BRONZE Certified Active PFC Power Supply - Newegg.com
Newegg.com - EVGA 01G-P4-3655-KR GeForce GTX 650 Ti BOOST 1GB 192-bit GDDR5 PCI Express 3.0 x16 SLI Support Video Card

could that be the reason it doesnt boot up ? could there be any other reasons ? does the gpu work with the mobo ?Help would be appreciated!
simon
__________________

jm123777 is offline   Reply With Quote
Old 06-05-2013, 07:17 PM   #2 (permalink)
Junior Techie
 
Wrenches's Avatar
 
Join Date: Apr 2013
Location: USA
Posts: 83
Default Re: help with my ram + mobo

It should've booted with one stick of ram. Your problem lies somewhere else.

Do you have the 4/8 pin CPU power plugged in?
__________________

Wrenches is offline   Reply With Quote
Old 06-05-2013, 08:04 PM   #3 (permalink)
Build Guru
 
PP Mguire's Avatar
 
Join Date: Dec 2004
Location: Fort Worth, Texas
Posts: 28,286
Default Re: help with my ram + mobo

Quote:
Originally Posted by jm123777 View Post
hi there,
after a lot of research and thinking I bought these computer parts from newegg and put them together, now it doesnt boot up.i googled a little and figured out that my mobo supports only dual channel rams. and i bought only one stick of ram. here are my parts.

Newegg.com - ASRock B75M-DGS R2.0 LGA 1155 Intel B75 SATA 6Gb/s USB 3.0 Micro ATX Intel Motherboard
G.SKILL Ripjaws Series 4GB 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10666) Desktop Memory Model F3-10666CL9S-4GBRL - Newegg.com
Intel Core i5-3330 Ivy Bridge 3.0GHz (3.2GHz Turbo) LGA 1155 Quad-Core Desktop Processor Intel HD Graphics 2500 BX80637i53330 - Newegg.com
CORSAIR Builder Series CX500 500W ATX12V v2.3 80 PLUS BRONZE Certified Active PFC Power Supply - Newegg.com
Newegg.com - EVGA 01G-P4-3655-KR GeForce GTX 650 Ti BOOST 1GB 192-bit GDDR5 PCI Express 3.0 x16 SLI Support Video Card

could that be the reason it doesnt boot up ? could there be any other reasons ? does the gpu work with the mobo ?Help would be appreciated!
simon
Everything is compatible.

Quote:
Originally Posted by Wrenches View Post
It should've booted with one stick of ram. Your problem lies somewhere else.

Do you have the 4/8 pin CPU power plugged in?
This.

Check to make sure all cables are secure and that the video card and RAM is seated properly. Make sure the RAM stick is in the slot closest to the CPU. Clear the CMOS is you have to.

If all of this fails take the GPU out and the motherboard. Place the motherboard with no HDD or extra USB plugged in on the motherboard box for a test bed and plug your monitor into the onboard video.
__________________
"Resolution is just a number." #Ubisoft
Origin/Steam = PP_Mguire Twitch = pp_mguire Instagram = ppmguire PSN = PP_Mguire

Access to my Plex PM me.
PP Mguire is offline   Reply With Quote
Old 06-05-2013, 09:34 PM   #4 (permalink)
Newb Techie
 
Join Date: May 2013
Location: US
Posts: 11
Default Re: help with my ram + mobo

This issue could be any number of issues.

A few questions
1 When you boot up is there any beeping?
2 Do you even get to the motherboard screen (bios)?
Shadowxsx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:59 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.