Got my Saitek Eclipse Today!!! - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Closed Thread
Thread Tools Display Modes
Old 11-29-2005, 06:50 PM   #11 (permalink)
Monster Techie
Join Date: Apr 2004
Posts: 1,842
Send a message via AIM to lazerman Send a message via Yahoo to lazerman

My whole setup is blue... So it works.

The Stargate MMORPG
lazerman is offline  
Old 11-29-2005, 07:29 PM   #12 (permalink)
Ultra Techie
Join Date: Mar 2005
Location: Illinois
Posts: 609

LoL Mine too, even my LCD is blue, lol, jk... anyway. I just found it sexy, I didn't think I would come back to my post in 5 min. and have 11 replies rofl.


•AMD 8120 @ 3.8Ghz
•CoolerMaster Hyper212 EVO
•MSI 970A G46
•8GB Dual-Channel 1600Mhz DDR3 Corsair Vengeance
•eVGA 660 GTX Ti
•128gb Samsung 830 SSD (OS, Games)
•2TB Seagate 7200rpm 64mb Barracuda SATA6GB's
•640gb WD (Cavier Blue)
•CoolerMaster HAF-X
AuThoRitY is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:15 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.