Got my new stuff-got issues - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Click Here to Login
Register FAQ Community Calendar Today's Posts Search Log in
Closed Thread
 
Thread Tools Display Modes
 
Old 01-19-2010, 10:05 AM   #1 (permalink)
Banned
 
Join Date: Dec 2008
Posts: 326
Default Got my new stuff-got issues

I finally got my new monitor, a Samsung XL2370 LED backlit, 1920x1080 23".

I also installed my new XFX XXX edition 5870.

Games like FEAR, L4D2, Crysis, and Bioshock all seem to work like they're supposed to...except my favorite game, UT2004.

Yep, UT2004 used to run at a near-steady 80+ fps with my HD 4830 and now I'm lucky to get 35 fps.

Also, it seems like the refresh rate of the monitor, (60hz) is kinda low compared to my NEC 90gx2 which could do a very nice 75hz. Believe it or not, I notice quite a difference.

So far, I'm not at all happy with the $750 "upgrade" that I just made.


I guess I'm looking for advice, especially on the low fps thing in UT2004 and wondering if I may be overlooking something.
__________________

newbiebuilderguy is offline  
Old 01-19-2010, 11:19 AM   #2 (permalink)
Lady Techie
 
Yami's Avatar
 
Join Date: Dec 2008
Location: UK
Posts: 7,773
Default Re: Got my new stuff-got issues

UT4k just won't be designed to work with the current ATi drivers. The best you can hope for is installing the latest patch for it, probably.
__________________

__________________
Desktop i5-4440 - ASRock Z77 Extreme4 - EVGA GTX970 - 4x4GB 1600MHz - Samsung 850 EVO 250GB - Be Silent Base 800 - 3TB+1TB+1TB+640GB
Laptop i7-3740QM @ 2.7GHz, 2x4GB 1600Mhz, GT640M, OCZ Agility 3 120GB
Smartphone Galaxy S7 Edge

LinkedIn Kiera Mitchell
Yami is online now  
Old 01-19-2010, 11:27 AM   #3 (permalink)
Master Techie
 
Whirlwind's Avatar
 
Join Date: Jan 2006
Posts: 2,400
Default Re: Got my new stuff-got issues

I am not sure what the problem is, but I still play UT2004 from time to time and with the GTX260 the frames are thru the roof....so your card should eat that game up.
__________________
Cooler Master CM Stacker Case
Asus P8Z68 V Pro/Gen 3
Intel i5-2500K
Cooler Master V6 GT Heat Sink
8 GB G-Skill DDR 3 1600
GTX 570 SLI
Asus Xonar Essence STX Sound Card
Grado RS1i & AKG Q701 Headphones
MAD EAR + HD Headphone Amp
Corsair CMPSU 850 Watt
Western Digital Black 500 GB
Crucial M4 64 GB SSD For Windows 7 64 Bit
Samsung 2494SW 24" LCD
Logitech G5 Mouse
Logitech G110 Keyboard
Whirlwind is offline  
Old 01-19-2010, 02:49 PM   #4 (permalink)
Banned
 
Join Date: Dec 2008
Posts: 326
Default Re: Got my new stuff-got issues

Yeah I have the latest patch, latest drivers, tried drivercleaner, even formatted the hdd. The card just won't run UT2004.
newbiebuilderguy is offline  
Closed Thread


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battlefield 2/gamespy ID issues, and mic issues. Help! Chad711 PC Gaming 14 09-07-2009 03:19 PM
MacBook Pro Firmware Updates Fix HDD, Bluetooth Issues Osiris Apple and Mac 0 08-20-2009 12:40 PM
AGP Video Card Issues (Nvidia GeForce 6200A) Superdad55 Hardware Repairs and Troubleshooting 8 08-05-2009 03:41 PM
9800 GT Issues virus_1 Hardware Repairs and Troubleshooting 11 06-13-2009 04:32 AM
custom stuff taintedplay Buy/Sell/Trade and Hot Deals 10 01-10-2009 06:44 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.