g80? now i'm conufused - Page 3 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Closed Thread
Thread Tools Display Modes
Old 10-31-2006, 07:29 AM   #21 (permalink)
Super Techie
small256's Avatar
Join Date: Mar 2006
Location: Somerset, England
Posts: 275

no it's done me well til now, but it's got a definite lag now, compared to all the other computers in the house. that and i like keping as up to date as possible

i5 2500K, MSI GTX 570 OC, 8GB G.Skill RipJawsX 1600MHz, 1TB WD Caviar Black, Zotac Z68ITX, Lian Li PC-Q08B
small256 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:38 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.