ERROR: Initialise3DEnvironment - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 03-10-2008, 08:59 PM   #1 (permalink)
Super Techie
 
Join Date: Apr 2006
Posts: 471
Default ERROR: Initialise3DEnvironment

I got a new 2600 Pro (8x AGP) card, and the latest drivers installed for it.
DirectX is updated, and we've even tried older versions of the driver.
When we go to play World of Warcraft for example, it will load the login screen, but it will flicker back and forth from the desktop to the world of warcraft screen. This appears to be the case for everything that tries to load full screen.
No 3D games will load, but 2D games will.
When I tried to run the Stability Test for grapics cards (the ones with the floating earth thing that spins around) it gave a more detail error.
Quote:
Plug and Play Monitor ATI Radeon HD 2600 Series 1280x1024 WIN5.1 Service Pack 2 DirectX 9.0c installed Generic application error. ERROR: -2005530518 Source: Initialize3DEnvironment Generic application error. ERROR: -2005530518 Source: Stability Test Generic application error. ERROR: -2005530518 Source: Initialize3DEnvironment
All the drivers do the same thing . That's the first thing I thought of, but it really annoyed me when like all the drivers did the same thing. Right now we're using 8.43... I'm so stumped as to what this can be. Does anyone think a reinstall of WinXP would be the solution?

System specs:
Athlon XP 2400+ socket A
DDR 133 MHz (266) 2-2-2-6
ASUS A7N8X2.0 nForce 2 mobo
HD 2600 Pro (AGP)
Windows XP SP2 32 bit
__________________

__________________
[CPU: e6600 @ 3300 MHz] // [MB: ASUS P5N-E SLi] // [RAM: Patriot 'eased latency' PC2-6400 @ DDR800 5-4-4-12-2T] // [GPU: 8800GTX @ 650/1000/1600 (volt modded)] // [HDD: 2x Cavier 500GiB stripe] // [Chassis: Thermaltake Armor VA8000 (black)] // [PSU: Aspire(Apevia) 680w] // [OS: Windows 7 Ultimate x64][Cooling: water cooled GPU and CPU]
^ (9/7/2010): Ha, I remember when that was the stuff. My water cooling has since leaked and fried my mobo. So now I'm rocking an MSI laptop with an i5 430m :)
lazer_viking is offline  
Old 03-11-2008, 07:07 AM   #2 (permalink)
Hard Gay Nahalem! Fooo!
 
NosBoost300's Avatar
 
Join Date: Nov 2005
Location: Bellflower, CA
Posts: 10,154
Send a message via AIM to NosBoost300
Default Re: ERROR: Initialise3DEnvironment

tried reinstalling direct x yet? or uninstalling previous drivers from the last graphics drivers
__________________

__________________
Current Build:
Intel 3770k @ 4.4 GHZ | Galaxy GTX 770 SLi | 16 GB G.Skill Sniper | ASrock z77 Extreme4
2xSamung 840pro 128GB in Raid | 2x1TB Seagate | Antec 750 Watt GamerSeries
Media Build:
Intel Core i3 3220 | Galaxy GTX 650 | 8 GB Corsair Vengeance | ASrock B75M | Samsung 840 120GB
NosBoost300 is offline  
Old 03-13-2008, 07:26 PM   #3 (permalink)
Super Techie
 
Join Date: Apr 2006
Posts: 471
Default Re: ERROR: Initialise3DEnvironment

Well, this thread was actually for a friend. He ended up taking back the 2600 pro and got a 7600 gs.

Yes, we did try reinstalling DX...

But how do you uninstall graphics drivers? We looked through the list of add/remove programs and took out everything we saw, but that just felt very very ineffective. As far as I know, there isn't like a list of installed drivers..? How would one wipe out all installed graphics drivers?
__________________
[CPU: e6600 @ 3300 MHz] // [MB: ASUS P5N-E SLi] // [RAM: Patriot 'eased latency' PC2-6400 @ DDR800 5-4-4-12-2T] // [GPU: 8800GTX @ 650/1000/1600 (volt modded)] // [HDD: 2x Cavier 500GiB stripe] // [Chassis: Thermaltake Armor VA8000 (black)] // [PSU: Aspire(Apevia) 680w] // [OS: Windows 7 Ultimate x64][Cooling: water cooled GPU and CPU]
^ (9/7/2010): Ha, I remember when that was the stuff. My water cooling has since leaked and fried my mobo. So now I'm rocking an MSI laptop with an i5 430m :)
lazer_viking is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:48 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.