dude I might get a dell - Page 4 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > New Systems | Building and Buying
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 08-03-2006, 09:37 PM   #31 (permalink)
Lord Techie
 
gurusan's Avatar
 
Join Date: Jan 2006
Location: Portland, OR
Posts: 6,562
Send a message via MSN to gurusan
Default

i bought an inspiron 5150 from them about 3 years ago. Within a few months, the ac adapter port went bad and I sent it in for warranty...got it back a week later....

then it happened again....did the same thing and sent it in for repair.....then yup...a short while later it happened AGAIN!

This time when I sent it in...they LOST IT!! Then since they discontinued the inspiron 5150 they were going to give me something with a pentium M 1.4 ghz.

I had a P4-M 3.06 with HT.....not the most efficient or cool processor..but it's certainly loads better than a 1.4ghz centrino.

So I made a fuss and then they sent me a "refurbished" 5150.

...and then guess what? The same ****ing problem happened again...the **** AC adapter port went bad. Now my warantee is out.

And something i didn't mention was that I spent probably 20+ hours on the phone total with people in India....they all had thick accents, and the connection was always horrible...and occasionally I would be disconnected after being put on hold for an hour or so

Basically...DON'T BUY DELL. They ****ing suck ***
__________________

__________________
|| 2500K @ 5GHz 1 thread, 4.8 2 threads, 4.6 3, 4.5 4 1.284V ||
|| P8P67-M Pro || 8GB @ 2133MHz ||
|| 5850 @ 1000/1225 || XFX 650W || Silverstone FT03B ||
|| 37" LCD TV || CM Hyper 212+ || Samsung 2.1 Soundbar ||
gurusan is offline  
Old 08-03-2006, 09:39 PM   #32 (permalink)
Monster Techie
 
Join Date: Jul 2006
Location: New Stanton, Pennsylvania
Posts: 1,017
Send a message via AIM to psp_crazy1
Default

Quote:
Originally posted by gurusan
i bought an inspiron 5150 from them about 3 years ago. Within a few months, the ac adapter port went bad and I sent it in for warranty...got it back a week later....

then it happened again....did the same thing and sent it in for repair.....then yup...a short while later it happened AGAIN!

This time when I sent it in...they LOST IT!! Then since they discontinued the inspiron 5150 they were going to give me something with a pentium M 1.4 ghz.

I had a P4-M 3.06 with HT.....not the most efficient or cool processor..but it's certainly loads better than a 1.4ghz centrino.

So I made a fuss and then they sent me a "refurbished" 5150.

...and then guess what? The same ****ing problem happened again...the **** AC adapter port went bad. Now my warantee is out.

And something i didn't mention was that I spent probably 20+ hours on the phone total with people in India....they all had thick accents, and the connection was always horrible...and occasionally I would be disconnected after being put on hold for an hour or so

Basically...DON'T BUY DELL. They ****ing suck ***
wow, i would b**** slap dell of that
wow cheap freaks
>
__________________

psp_crazy1 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:43 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.