XPpro/SP2 64 bit - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Closed Thread
Thread Tools Display Modes
Old 09-12-2006, 01:19 PM   #11 (permalink)
Monster Techie
Join Date: Jul 2004
Location: Manchester, UK
Posts: 1,909

I have AMD 64 BIT, but in very true opinion, do not use 64-bit O/S until Vista, as by then, probably 80% of the softwares should have become 64-bit, as now if you use 32bit applications on 64-bit o/s, they'll tend to be slow compared to running on 32bit O/S. i as well went to buy a 64-bit as when i bought mine 4400+, but at the last minute keeping all things in mind, I cancelled my program. also, there miht be some hardware driver issues also on 64-bit O/S. so better wait for Vista. like I am doing.

Intel Core2Quad 2.66Ghz 12MB L2-Cache
4096MB DDR Kingston Hyper-X
GigaByte GA-P35-DS3R
XFX 9600GT AlphaDog
Seagate 2 X 320GB SATA2
LG L246WH Flatron 24"
Blind_Arrow is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:35 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.