X-Fi XtremeSound Card Problems - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 12-03-2005, 11:13 AM   #1 (permalink)
Junior Techie
 
Join Date: Nov 2005
Posts: 57
Send a message via AIM to chrispowell
Default X-Fi XtremeSound Card Problems

OK so i bought myself the xfi XtremeMusic Sound Card from newegg i put it in my computer and it works great sound and stuff. but then last night i tried to put my headset in.. well my mic. AND i can here everything i do and what they say.. how can i get ride of this?
__________________

chrispowell is offline  
Old 12-03-2005, 11:16 AM   #2 (permalink)
Junior Techie
 
Join Date: Nov 2005
Posts: 57
Send a message via AIM to chrispowell
Default

OK and now im haveing a problem again with the sound.... After a while intead of makeing the ding noises or click noises it will make a annoying buz noise when any noise is played. help someone plz
chrispowell is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.