Sound card? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 03-10-2007, 08:54 PM   #1 (permalink)
Content Team
 
Join Date: Apr 2005
Location: Ontario, Canada
Posts: 184
Send a message via AIM to blackhawk13
Default Sound card?

Hey everyone, I was going to just implement this into my last thread, but meh, I figure I'll start up another one with a different title... Anyways, I'm going to be using these speakers:

http://canadacomputers.com/index.php...=009432&cid=SP

And a P5B-Deluxe mobo... Now, for me to get the entire surround sound experience (I will have my computer hooked up to a 37" LCD, so that I can play DVD's/Games on that), will the mobo do? Or should I purchase this:

http://canadacomputers.com/index.php...=008774&cid=SC

Or will I need something more? Thanks for the help!
__________________

blackhawk13 is offline  
Old 03-10-2007, 10:32 PM   #2 (permalink)
Super Techie
 
Capricorn's Avatar
 
Join Date: Aug 2004
Location: Northern VA
Posts: 372
Default

Technically, there's no reason you couldn't use those speakers with that motherboard. It has AD1988B 8-channel onboard sound chip, which is the same one I have. I'm using a 4.1 Speaker system with it rather than 5.1, but it has center & subwoofer channel sockets (as well as a SPDIF) available. I'd recommend trying those with the onboard sound first. It doesn't cost you anything to try it. If you aren't happy with them, you can always add a sound card later.

If you do go with a sound card, I'd probably spring for something a bit higher on Creative's food chain than the Audigy SE. Something in the Sound Blaster X-Fi series. Those can be had for under $70 US. (Canada Computers doesn't sell those though.)
__________________
Case: Enermax CS-A106USB
P/S: OCZ OCZ700GXSSLI 700W
Motherboard: ASUS P5N32-E SLI
CPU: Intel E6300(idle 35C/load 39C)
RAM: OCZ Platinum Rev 2 DDR2 800 MHz (4 x 1GB) 4-4-4-15-T1 (2.1v)
Hard Disk: Seagate 2x250GB SATA ST3250620AS in RAID1
Monitor: Mitsubishi DP900u
Graphics: BFG GeForce 8800GT PCI-E
Sound: SoundBlaster X-Fi Fatal1ty
Speakers: Klipsch ProMedia v.2-400 4.1 speakers
Optical: LiteOn 16X DVD-ROM; Sony DRU-710A DVD-RW
Capricorn is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.