Sapphire ATI 850 Pro - unknown device - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 04-26-2007, 09:58 PM   #1 (permalink)
Newb Techie
 
Join Date: Apr 2007
Posts: 14
Default Sapphire ATI 850 Pro - unknown device

Hi, long time lurker, first post

I just purchased this video card and downloaded the latest driver. After installing the card and driver only, the card seems to function just fine but when I look in the device manager there is an unknown device.

When I include WDM drivers in the driver installation, the unknown device goes away, but graphics slow to a snails pace and my DDO game does not recognize the device, so I reinstalled the driver only.

I'm not even sure this is even a problem, but I figured it wouldn't hurt to ask.

Thanks in advance of any input.
__________________

uglytobone is offline  
Old 04-27-2007, 10:31 PM   #2 (permalink)
Junior Techie
 
Join Date: Apr 2007
Posts: 49
Default Re: Sapphire ATI 850 Pro - unknown device

1)Install latest drivers
2)Re-install latest drivers
3)Has it got a warranty?
__________________

Antz. is offline  
Old 04-28-2007, 12:01 AM   #3 (permalink)
Retired.
 
peterhuang913's Avatar
 
Join Date: Dec 2005
Location: Los Angeles, California
Posts: 8,076
Send a message via AIM to peterhuang913
Default Re: Sapphire ATI 850 Pro - unknown device

RMA and get a replacement
__________________


My computer uses 1.5A-load, .8A-idle, .65A-standby, .05A-turned off on 125V.
"The spaces between your fingers were created so that another's could fill them in."
Quote:
Originally Posted by Norcent View Post
I need to stop using the internet.
peterhuang913 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HL-DT-ST RW/DVE GCC-4481B ATA Device & Windows Vista NenaGb Hardware Repairs and Troubleshooting 0 04-05-2007 05:16 PM
How to know the IP address and port number of a device connected to PC through LAN Sunil Computer Networking and Internet Hardware 2 04-01-2007 07:53 PM
A good Network Storage Device? Bengal313 Monitors, Printers and Peripherals 2 03-31-2007 05:57 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.