Radeon 4870X2 - No video on startup - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Closed Thread
Thread Tools Display Modes
Old 05-13-2009, 10:48 AM   #1 (permalink)
Newb Techie
Join Date: May 2009
Posts: 3
Default Radeon 4870X2 - No video on startup

So a friend and I put together a new rig, fired it up - no visual to my monitor.

Using setup as follows -
Newegg.com - SAPPHIRE 100251SR Radeon HD 4870 X2 2GB 512-bit (256-bit x 2) GDDR5 PCI Express 2.0 x16 HDCP Ready CrossFire Supported Video Card - Desktop Graphics / Video Cards (4870X2)
Newegg.com - Western Digital Caviar Green WD10EADS 1TB 32MB Cache SATA 3.0Gb/s 3.5" Internal Hard Drive - Internal Hard Drives (WD HDD)
Newegg.com - GIGABYTE GA-MA780G-UD3H AM2+/AM2 AMD 780G HDMI ATX AMD Motherboard - AMD Motherboards (Gigabyte mobo)
Newegg.com - RAIDMAX HYBRID 2 RX-730SS 730W ATX12V V2.2/ EPS12V SLI Ready CrossFire Ready Modular Modular LED Power Supply - Power Supplies (PSU)
Newegg.com - AMD Phenom II X4 955 Black Edition Deneb 3.2GHz 4 x 512KB L2 Cache 6MB L3 Cache Socket AM3 125W Quad-Core Processor - Processors - Desktops (Processor)
Newegg.com - CORSAIR 4GB (2 x 2GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400) Dual Channel Kit Desktop Memory - Desktop Memory (RAM 2x)
Newegg.com - Sony Optiarc Black 24X DVD+R 8X DVD+RW 12X DVD+R DL 24X DVD-R 6X DVD-RW 12X DVD-RAM 16X DVD-ROM 48X CD-R 32X CD-RW 48X CD-ROM 2MB Cache SATA DVD/CD Rewritable Drive - CD / DVD Burners (DVDRW)
Newegg.com - Antec Three Hundred Black Steel ATX Mid Tower Computer Case - Computer Cases and the case.

So anyway we got everything - connectors have been checked and double checked - PCIe 2x3 and 2x4 have been checked and double checked. And the monitor has been checked and double checked with a different PC. The card is getting power it seems, fan is on and whatnot - and what we're noticing is 3 solid red LEDs on the card.

Any suggestions would be awesome.

Adept is offline  
Old 05-13-2009, 11:21 AM   #2 (permalink)
Equator Gringo
james.wired's Avatar
Join Date: Nov 2008
Location: Panama
Posts: 2,318
Default Re: Radeon 4870X2 - No video on startup

You need to really make sure that card is seated correctly.

james.wired is offline  
Old 05-13-2009, 12:08 PM   #3 (permalink)
True Techie
up-smash's Avatar
Join Date: Apr 2009
Location: Hawaii
Posts: 157
Default Re: Radeon 4870X2 - No video on startup

I had a problem with that, the power supply wasn't in correctly. There were also some plugs that weren't in

You need to make sure that all the power supply plugs are in correctly
up-smash is offline  
Old 05-13-2009, 12:10 PM   #4 (permalink)
Lord Techie
Hefemeister's Avatar
Join Date: Feb 2004
Location: Sweden
Posts: 9,093
Default Re: Radeon 4870X2 - No video on startup

Since that board has onboard video, have you gone into bios and changed that to pci-e?

Do you get monitor signal when connected to the onboard?
ASUS P6T Deluxe V2 :: INTEL i7 920 @3.4 :: XFX GTX260 :: 6gb Corsair 1600 :: Corsair 750TX :: TRUE 120 :: Samsung T240 24" :: Windows 7 X64

I do not accept support questions via PM

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
Hefemeister is offline  
Old 05-13-2009, 04:30 PM   #5 (permalink)
Wizard Techie
HAVOC's Avatar
Join Date: Feb 2005
Location: Milford, Connecticut
Posts: 4,218
Send a message via AIM to HAVOC Send a message via Yahoo to HAVOC
Default Re: Radeon 4870X2 - No video on startup

Have you tried all the DVI connectors on the card? Because I know for a fact that before I configured my CCC drivers for my 4850X2 I had the same issue. I had to try all four of the DVI ports before I finally found the one that worked. It has something to do with the drivers I think.
HAVOC is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble with older Sony using new video card CeeJay Hardware Repairs and Troubleshooting 5 12-10-2008 02:13 PM
Need help in choosing Video Cards Under $130 r3n3r4d3 System Upgrades 31 10-22-2007 02:54 PM
video ipod RavishingRocket Apple and Mac 1 06-20-2006 01:13 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:44 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.