Noob question - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Closed Thread
Thread Tools Display Modes
Old 10-23-2006, 04:19 PM   #1 (permalink)
Newb Techie
Join Date: Oct 2006
Posts: 19
Unhappy Noob question

Alright I finally found the card Im gonna buy but after reading around what it requires It says I need "one internal power connector", it seems all the connectors coming from the power supply are plugged in on the motherboard. The only one I managed to find was one coming off the HD and floppy (it had 4 prongs), is this what they mean? This must seem like an idiotic question, if it helps I have a 400W ATX CODEGEN powersupply and this is the card:

shifty2991 is offline  
Old 10-23-2006, 05:26 PM   #2 (permalink)
Wizard Techie
Join Date: Jan 2005
Location: Delaware
Posts: 3,475

It uses a 4 pin molex (same as the optical drives...)
turtile is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:25 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.