Just got done with my first build, but UGH!! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 04-06-2011, 09:26 PM   #1 (permalink)
Junior Techie
 
Join Date: Mar 2009
Posts: 61
Angry Just got done with my first build, but UGH!!

Being the clumsy fool that I am, I forgot to screw in the side panel and picked the case up only to have the side panel fall to the ground, tearing these wires in the process. I could not be anymore angry with myself. I finally got it all fixed, but I freaking BROKE the wires to the LED fans on the door. This ****es me off.

Anyway, what must I do to fix this? Can I just "hoborig" it by somehow twisting the wires together? I really don't want to do that, so it looks like I'll have to buy two more fans? UGH!!! Here's a pic:



The little black thing in the bottom left of the corner is the attachment that SHOULD be on the end of those wires. Ugh please help me, this is so frustrating to know that it could've been easily prevented. I'm such a retard. Thanks in advance.

This is my case.
__________________

Sidewalk is offline  
Old 04-06-2011, 10:03 PM   #2 (permalink)
Junior Techie
 
Join Date: Mar 2009
Posts: 61
Default Re: Just got done with my first build, but UGH!!

Maybe I could call Newegg and see if I can get a replacement? The fans, apparently are specially made for this specific case.
__________________

Sidewalk is offline  
Old 04-06-2011, 10:14 PM   #3 (permalink)
 
patonb's Avatar
 
Join Date: Jan 2005
Location: In Gov't Regulated Cubical
Posts: 9,745
Default Re: Just got done with my first build, but UGH!!

You should beable to get them bsck in, they don't look broken off, more like pulled out.

I'd look more into the plug and see if theyre just pressed in.
__________________
Foldie = i5 6600kMSI Z170A M5 EVGA 970 SC Corsair H100 Corsair hx520 2x8gb GSkill Corsair 650D
Woohoo = L5639 @3.1Ghz EVGA SR-2 gtx 260-216 Hyper 212+ Corsair 1050hx 6x2gb Corsair XMS3 Blackhawk Ulra
Alienware 18 - SLI 770M 4700mq 16Gig

patonb is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP ON NEW BUILD! Sandy Bridge i7-2600k FIRST BUILD EVER!! Tips are highly appreciated! bvuong New Systems | Building and Buying 5 01-12-2011 07:09 PM
First post - First build - HT/Media/Multi-Task Build Reco's? delirium330 New Systems | Building and Buying 60 01-12-2009 03:07 PM
Buddies thinking new build for Video Editing... Would a gaming build work ? Rakie New Systems | Building and Buying 6 01-04-2008 02:30 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.