Just bought 7600GS - Power Issues - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 11-25-2007, 10:23 AM   #1 (permalink)
True Techie
 
Join Date: Dec 2005
Posts: 162
Question Just bought 7600GS - Power Issues

ok I recently upgraded from a radeon 9700PRO to 7600GS.
First of all the 7600 runs faster than the 9700pro, however it has made a really small difference and is more unreliable (random heavy fps lagg that wasnt previously there).

I think its my PSU ( 450 WATT). But 12V on 19A, I expected a massive difference i have had almost no improvement, is this down the my psu being too low.

Thanks.
__________________

lea0001 is offline  
Old 11-25-2007, 10:31 AM   #2 (permalink)
TF's First Dry Ice User!
 
Peter.Cort's Avatar
 
Join Date: Jul 2007
Location: Boston, MA
Posts: 5,018
Default Re: Just bought 7600GS - Power Issues

its not your psu. its the card. i hate to tell you but the card isn't very good. i had the same problem, i went from a 9200se to the 7600GS and could play games on higher res, but that was it. if you still can return the card and atleast get a GT or a better card if you can.
__________________

__________________
A notice to EVERYONE who has posted here with a computer problem, I highly encourage you to keep current with the forums, even if it's browsing for 10-15 minutes during lunch, or before you go to bed at night. There are many things that you can learn and apply to future issues. My goal is to help people get to a point where they can use their own knowledge to help themselves, and others.

Also please use the search button. You've got a 50/50 chance that someone's asked your question and we've answered it.
Peter.Cort is offline  
Old 11-25-2007, 05:19 PM   #3 (permalink)
True Techie
 
Join Date: Dec 2005
Posts: 162
Default Re: Just bought 7600GS - Power Issues

ouch, i spent $150 (Australian) on that **** card.
Is there anything I can do to improve its perfomance which I havent tried already?
lea0001 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
POST Troubleshooting Guide SYL\X/3K Hardware Repairs and Troubleshooting 7 03-07-2009 11:24 AM
Built a new computer...NO POWER!!! HELP!!! imconfused System Upgrades 33 11-26-2007 08:32 PM
Echo Star 600W 20+4 Pin ATX Power Supply commandercup New Systems | Building and Buying 3 09-04-2007 07:21 PM
HDD power issues rhys06 Hardware Repairs and Troubleshooting 1 06-11-2007 05:00 PM
power issues cristo33 Hardware Repairs and Troubleshooting 1 05-01-2007 09:47 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.