Installed Thermaltake Big Typhoon - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Closed Thread
Thread Tools Display Modes
Old 07-31-2007, 12:34 AM   #1 (permalink)
True Techie
Join Date: Jul 2007
Posts: 122
Default Installed Thermaltake Big Typhoon

I just thought i'd share my experience. tonight when i got home from work, my new thermaltake big typhoon, CPU cooler had arrived. so i qive a quick read over the instructions, then begin to install the new cooler. All went well and it took about an hour (because i had to disassemble everything and remove the motherboard) but other than having to remove the motherboard it work flawlessly. needless to say i was very pleased that after putting everything back together, the system started right up without a hitch. not to mention the instant drop in temperature from an idle temp of 60-62 C (with stock cooler) to 48 C idle, (with new cooler) i am still going to replace my stock case fan as well. I am also very pleased with how quiet the thermaltake big typhoon is, as it only runs at around 1300 - 1500 RPMs on normal running conditions. s apposed to the 3000-4000 RPMs that the stock cooler ran at. (very Loud) anyways. this seems to be a good product and i will upsate after a few months of running it, to see if it can hold it's own. Take care

Wverb0783 is offline  
Old 07-31-2007, 02:04 AM   #2 (permalink)
saltynay's Avatar
Join Date: Dec 2006
Location: West Coast, Singapore
Posts: 5,149
Default Re: Installed Thermaltake Big Typhoon

take some pictures of your rig and post them now that it is semi complete

have you done some wire management often you can drop a surprising amount of heat just by tidying a few wires and hiding a couple of cables beneath the mobo. its a difficult job though could take you a while

saltynay is offline  
Old 07-31-2007, 04:24 PM   #3 (permalink)
True Techie
Join Date: Jul 2007
Posts: 122
Default Re: Installed Thermaltake Big Typhoon

I will post some pics after I put evrything into the new THERMALTAKE tsunami case I just bought.
Wverb0783 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Core 2 duo stay away from thermaltake big typhoon. Raknor Overclocking and Modding 14 06-20-2007 04:31 PM
Installed new mobo/ram/cpu but nothing shows on screen? jonny_uk Hardware Repairs and Troubleshooting 3 06-12-2007 01:54 PM
I bought the Thermaltake Toughpower 750Watts pinoy3000 New Systems | Building and Buying 13 06-05-2007 10:43 AM
Just installed Vista, very good but 2 issues please help! jonny_uk Microsoft Windows and Software 2 06-03-2007 02:53 PM
Does the Acer Windows Vista have to be installed on a ACER or on ANY PC? Comptech Microsoft Windows and Software 3 04-09-2007 05:25 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:01 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.