I'm lost *PLEASE HELP* - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 03-16-2015, 06:31 AM   #11 (permalink)
Build Guru
 
PP Mguire's Avatar
 
Join Date: Dec 2004
Location: Fort Worth, Texas
Posts: 28,306
Default Re: I'm lost *PLEASE HELP*

That's because you have to follow the directions and put the AMD mounting solution on the block.
__________________

__________________
"Resolution is just a number." #Ubisoft
Origin/Steam = PP_Mguire Twitch = pp_mguire Instagram = ppmguire PSN = PP_Mguire

Access to my Plex PM me.
PP Mguire is offline   Reply With Quote
Old 03-16-2015, 08:29 AM   #12 (permalink)
Newb Techie
 
Join Date: Mar 2015
Location: United States
Posts: 7
Default Re: I'm lost *PLEASE HELP*

Quote:
Originally Posted by PP Mguire View Post
That's because you have to follow the directions and put the AMD mounting solution on the block.

The plastic piece? I tried to add it but it still didn't fit. Idk I might be doing something wrong, should I try to find a video on it?
-I'm new to all of this.


Sent from my iPhone using Tech-Forums
__________________

Trollerism is offline   Reply With Quote
Old 03-16-2015, 08:46 AM   #13 (permalink)
Build Guru
 
PP Mguire's Avatar
 
Join Date: Dec 2004
Location: Fort Worth, Texas
Posts: 28,306
Default Re: I'm lost *PLEASE HELP*

If you bought the cooler new from Newegg there will be an instruction guide in the box. Follow the steps for the AMD mounting. If you're new to this, that is the absolute first thing you should have done.
__________________

__________________
"Resolution is just a number." #Ubisoft
Origin/Steam = PP_Mguire Twitch = pp_mguire Instagram = ppmguire PSN = PP_Mguire

Access to my Plex PM me.
PP Mguire is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please Help! Please Help! Please Help! thebeliever Viruses, Spyware and Malware 7 12-27-2010 11:00 PM
weird things going on.. lost themes. now lost sounds.. clever_j Microsoft Windows and Software 2 12-20-2006 10:04 AM
Please help - my video card has lost it mahlerfan Computer Audio and Multimedia 2 12-21-2004 04:48 PM
I am lost! IM trouble! Website trouble! WEIRDEST PROBLEM EVER SEEM! Please help me! TheMajor Internet Software and Browsers 14 10-28-2004 01:55 AM
help!!!please?? lost my desktop themes chris f Microsoft Windows and Software 2 07-07-2004 01:38 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:10 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.