Having Problem with new Upgrades - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 03-30-2009, 05:46 AM   #1 (permalink)
Newb Techie
 
Join Date: Mar 2009
Posts: 2
Default Having Problem with new Upgrades

Dear All
Assalam-o-Alykum

I have just Upgraded my system and Here are the Specifications

Processor : 3.2 ghz Intel
Graphics Cad : HIS Radeon 4670 1GB DDR3 IceQ
Memory : 1 GB DDR3
Power Supply : AcBel 400 watts . (Cooler Master was not available)
Hard Disk : 160 GB

The Problem is that, Pro Evolution Soccer 2008 runs well in low graphics, but when i switch to medium or high then it is hardly playable. NFS ProStreet doesnot run that well either (too many jerks).

I am relatively new in PC gaming , Infact this is the first time i brought graphics card but according to the Game Specifications all games should be running well.

Please guide me in the right direction as what to do.

Thanks Alot
__________________

danish75 is offline  
Old 03-30-2009, 05:57 AM   #2 (permalink)
Lord Techie
 
Hefemeister's Avatar
 
Join Date: Feb 2004
Location: Sweden
Posts: 9,093
Default Re: Having Problem with new Upgrades

Have you installed the latest drivers for you card?
Graphics Drivers & Software
__________________

__________________
ASUS P6T Deluxe V2 :: INTEL i7 920 @3.4 :: XFX GTX260 :: 6gb Corsair 1600 :: Corsair 750TX :: TRUE 120 :: Samsung T240 24" :: Windows 7 X64

I do not accept support questions via PM

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
Hefemeister is offline  
Old 03-30-2009, 08:54 AM   #3 (permalink)
Newb Techie
 
Join Date: Mar 2009
Posts: 2
Default Re: Having Problem with new Upgrades

I have installed the drivers which came with it in CD...
danish75 is offline  
Old 03-30-2009, 09:02 AM   #4 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: Having Problem with new Upgrades

What Processor do you specifically have? Just saying a 3.2GHz Intel doesnt tell us much. Is it a Pentium 4, Intel Core 2 Duo, or a Core i7?

Run CPUz to get the processor information. It could very well be that your CPU is bottlenecking or just cant handle the load.
__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 03-30-2009, 09:51 AM   #5 (permalink)
Grandfather of Techist

\_(ツ)_/
 
Trotter's Avatar
 
Join Date: Jan 2005
Location: The South
Posts: 31,307
Default Re: Having Problem with new Upgrades

The HIS Radeon 4670 1GB DDR3 IceQ requires a 400W PSU. I am not familiar with your particular brand of PSU, but if it is iffy then it may not be supplying your card with enough power.

Try updating to the newest driver out, which is 9.3 (I think). Uninstall the current driver via Programs and Features. Boot into Safe Mode and use Driver Sweeper to remove what is left behind. Boot into Windows and install the new drivers.
__________________


My Rig: SABLE
Antec 300 Illusion / Antec EarthWatts EA650 650W / ASUS GeForce GTX 960 GTX960-DC2OC-2GD5
AMD FX 8320 x8 Black Edition / Gelid Tranquillo / MSI 970A-G43
Sandisk Ultra Plus 128GB / Samsung 840 120GB / WD Black 750GB / WD Green 1TB
2x4GB DDR3 1600 - 2x2GB DDR3 1600
Win10 Ent 64-bit - Mionix Naos 7000 Mouse - CM Storm QuickFire Rapid Mech Keyboard


R.I.P. Danny L. Trotter ... 14 Nov 1945 - 4 Sept 2009
Trotter is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Sound/Videocard Phase Hardware Repairs and Troubleshooting 6 05-02-2008 07:28 AM
Grand Theft Auto problem bmxfreakrider PC Gaming 0 01-13-2008 03:03 PM
Serious computer problem. HeeRoMaKi Hardware Repairs and Troubleshooting 71 07-28-2007 11:42 PM
Wireless Problem! dropper Computer Networking and Internet Hardware 3 07-08-2007 04:58 PM
Chronic Rebooting Problem AND_YOU_ARE Hardware Repairs and Troubleshooting 1 04-24-2007 06:04 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.