Hastily bought an X-Connect - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 08-29-2005, 02:15 PM   #1 (permalink)
Ultra Techie
 
Join Date: Aug 2005
Posts: 506
Default Hastily bought an X-Connect

I was having issues with the junk psu that came with my chassis when I built my computer, so I ran out and bought the first "nice looking" psu I could find at FRY's, a Ultra X-Connect. All the reviews I've read said it was a good unit, but from user feedback here and other places I'm finding out that its not. So I'm gonna take it back and tell em it didn't fit or something. But I've decided on a new psu.

ENERMAX Whisper II EG465P-VE FMA ATX12V 460W
+3.3V@35A, +5V@35A, +12V@33A, -12V@1A, +5VSB@2.2A
http://www.newegg.com/Product/Produc...82E16817103464

I don't have anything special
P4 640
ASUS P5RD1-V
512MB x2 DDR400
Maxtor DiamondMax 10 6L200M0 200GB SATA150
DVD-RW drive
DVD-ROM drive
6600GT PCI-E

That should be pleny power supply, eh?
__________________

cedjunior is offline  
Old 08-29-2005, 02:21 PM   #2 (permalink)
Lord Techie
 
Join Date: Jan 2005
Posts: 8,013
Send a message via AIM to DJ-CHRIS
Default

The Enermax looks good, and it's also a very new one as this is the first time I have seen them.

Yeah, Ultra's are not all that great :/
__________________

DJ-CHRIS is offline  
Old 08-29-2005, 03:00 PM   #3 (permalink)
Newb Techie
 
Join Date: Aug 2005
Posts: 2
Default

I recommend using a Antec PSU but that enermax sound real nice. If you want a quiet PSU get a Antec TruePower 2.0
tekkie is offline  
Old 08-30-2005, 09:12 AM   #4 (permalink)
Ultra Techie
 
Join Date: Aug 2005
Posts: 506
Default

Ok now for the wait. Ordered and shipped from newegg, will be here thurs. I'll have to make due with the x connect till then. I just hope this solved my video card problem that many have suggested was caused by the psu that came with the chassis I'm using which only has 15 12v amps.
cedjunior is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.