a good setup? - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 01-10-2006, 12:24 AM   #11 (permalink)
Super Techie
 
Join Date: Nov 2005
Posts: 378
Send a message via AIM to Anphrax
Default

Hm, dont really remember. I do know it was a demon, daemon or something like that. Its got a huge *** blue fan on the front of it. 480 W
__________________

__________________
Sig privileges back.

I love you sig santa :D
Anphrax is offline  
Old 01-10-2006, 12:27 AM   #12 (permalink)
Ultra Techie
 
Join Date: Oct 2005
Posts: 563
Default

Um possibly but it sounds like one of those third party powersupplies that might just stop working on you, which would be bad especially with the 6800GS.
To be safe I'd personally would go with a Fortron 450W, unless you want to risk it with your current one.
__________________

__________________
PcMe is offline  
Old 01-10-2006, 12:58 AM   #13 (permalink)
Super Techie
 
Join Date: Nov 2005
Posts: 378
Send a message via AIM to Anphrax
Default

what would happen if the power supply cut out? would it fry my system?
__________________
Sig privileges back.

I love you sig santa :D
Anphrax is offline  
Old 01-10-2006, 02:15 AM   #14 (permalink)
Junior Techie
 
Join Date: Jan 2006
Posts: 68
Default

I don't think so...
__________________

andy43 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.