First! - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Closed Thread
Thread Tools Display Modes
Old 08-20-2009, 05:48 PM   #11 (permalink)
Newb Techie
Join Date: Aug 2009
Posts: 5
Default Re: First!

I upped to a 650 watt PSU, directly connected to the card, still no dice. Tried a few other ram sticks, nothing either, checked the manual, ram is in correct place. Any other ideas? I bought this from newegg, returning it would be a hassle =p

r_Desio is offline  
Old 08-21-2009, 12:50 AM   #12 (permalink)
Junior Techie
TaBryan09's Avatar
Join Date: Aug 2009
Location: Massillon Ohio
Posts: 63
Default Re: First!

Newegg is realy good about returning products

Now for some Hardcore Troubleshooting

Pull one by one every cable, card, and front panel stuff off the board, (EXCEPT POWER SWITCH!) if your pulling and you go to check it and you get NOTHING at all then make sure you didn't pull your power switch off lol been there done that, also make sure you plug the power in everytime too, i hate stating the obvious but SH** HAPPENS lol, check it each pull until you are down to the CPU RAM and Vid

If nothing still i would pull your vid and slap in a cheapo PCI vid card and see if you get anything

also I would reset the CMOS, pop out the battery and unplug the power supply then press the power button for about 15secs then reinsert the battery and also check the mobo manual for the CMOS jumper settings and make sure it is set right

and if still nothing im going to have to say its a CPU issue, (worst case scenario!)

good luck

TaBryan09 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Great Beginner Build Guide Spit-wad New Systems | Building and Buying 5 04-29-2009 09:17 PM
Need advice on 1st time budget build Dudeman System Upgrades 6 04-12-2009 05:29 PM
$1000 CAD Build xxfirexx New Systems | Building and Buying 15 03-12-2009 04:00 PM
Windows 7 Build 7000 Beta Review KSoD Official TF Reviews 11 02-15-2009 12:33 PM
First PC build, any help appreciated. relapserebel System Upgrades 16 01-29-2009 12:02 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:39 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.