A few questions about my system - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 08-06-2010, 05:59 PM   #1 (permalink)
Newb Techie
 
Join Date: May 2010
Posts: 25
Default A few questions about my system

Hi, I recently bought starcraft 2 for gaming on my PC and the load screens are horrendous and my frame rates are horrible as well. I was wondering what affects load times and frame rates? I have friends that tell me to upgrade GPU and RAM, but never the CPU. What is the CPU's function when dealing with high end gaming?

Here are some of my systems specs:

Processor
2.80 gigahertz Intel Pentium D


Memory:

2 GB currently at 533 MHz, but i just ordered two more Gigs from newegg and they are on their way

GPU:

Radeon HD 4850 1GB

PSU:

375 W

I'm not sure how CPUs affect gaming and if mine is holding my system back, any help would be appreciated.
Thanks for taking the time to help,

Alex N.
__________________

Musketman007 is offline  
Old 08-06-2010, 07:33 PM   #2 (permalink)
Mod Emeritus
 
b1gapl's Avatar
 
Join Date: Nov 2004
Location: USA
Posts: 13,044
Default Re: A few questions about my system

Load times are mainly affected by the hard drive and also the amount of RAM. Although 2GB is adequate.

If it's an old 5400rpm drive, or it's heavily fragmented, that can cause slow load times of applications or programs.

Frame rates are mainly affected by your GPU, but also your CPU. You can have the most powerful GPU in the world, but if your CPU can't keep up with it, that GPU is useless.

According to SC2's minimum requirements, you more than meet them.

Make sure you have the latest drivers. Sound, graphics, etc.

Horrible frame rates and load times can also be caused by the resolution of your monitor that you play games with. As well as the graphic settings in a game. It can be set too high which could make a system struggle to play.
__________________

__________________


3770K | ASUS STRIX GTX 1080 | DDR3-1600 16GB | CORSAIR 650D | CORSAIR HX 850W | CORSAIR H100 | SOUND BLASTER Z | ASROCK EXTREME4 GEN3

b1gapl is offline  
Old 08-06-2010, 08:19 PM   #3 (permalink)
Newb Techie
 
Join Date: May 2010
Posts: 25
Default Re: A few questions about my system

Do you think having a PSU with too low a wattage could affect performance such as FPS? I currently have a 375w and my GPU recommends a 450w.
Musketman007 is offline  
Old 08-06-2010, 09:05 PM   #4 (permalink)
Mod Emeritus
 
b1gapl's Avatar
 
Join Date: Nov 2004
Location: USA
Posts: 13,044
Default Re: A few questions about my system

A 4850's max power draw is around 110W so 375W should be enough.

Has your system always had slow load times and low frame rates? Or was that only after you bought SC2?
__________________


3770K | ASUS STRIX GTX 1080 | DDR3-1600 16GB | CORSAIR 650D | CORSAIR HX 850W | CORSAIR H100 | SOUND BLASTER Z | ASROCK EXTREME4 GEN3

b1gapl is offline  
Old 08-06-2010, 10:40 PM   #5 (permalink)
Newb Techie
 
Join Date: May 2010
Posts: 25
Default Re: A few questions about my system

Well I only noticed it once I started playing starcraft 2. I played world of warcraft before on max settings and I never had a problem, but i think sc2 is a much more demanding game.
Musketman007 is offline  
Old 08-06-2010, 10:45 PM   #6 (permalink)
Mod Emeritus
 
b1gapl's Avatar
 
Join Date: Nov 2004
Location: USA
Posts: 13,044
Default Re: A few questions about my system

Try defragmenting your hard drives. Then update your graphic drivers to the latest. Also try to lower the settings a bit on SC2 if they're set at max.

If you're going to update the graphic drivers, the recommended way is uninstall like you normally would, download and install Driver Sweeper, then go into safe mode and use Driver Sweeper to remove the remainder of the drivers left, restart, and install the latest graphic drivers.
__________________


3770K | ASUS STRIX GTX 1080 | DDR3-1600 16GB | CORSAIR 650D | CORSAIR HX 850W | CORSAIR H100 | SOUND BLASTER Z | ASROCK EXTREME4 GEN3

b1gapl is offline  
Old 08-07-2010, 01:50 AM   #7 (permalink)
Newb Techie
 
Join Date: May 2010
Posts: 25
Default Re: A few questions about my system

I did everything you said for removing drivers and ended up getting stuck at the end. It won't let me install any drivers and I get an error message saying, "failed to load detection driver."I did a system restore to a few days ago and got the old drivers back, but now i'm getting an error when trying to download the sc2 updater. I read somewhere that said that sometimes driver cleaner removes too much. Bleh, why did i bother trying to update the driver.
Musketman007 is offline  
Old 08-07-2010, 08:59 AM   #8 (permalink)
Mod Emeritus
 
b1gapl's Avatar
 
Join Date: Nov 2004
Location: USA
Posts: 13,044
Default Re: A few questions about my system

You can try this solution:
"Failed to load detection driver" installation error

Something must of went wrong during the cleaning of drivers with the sweeper, because I do the same exact thing every time I update my graphic drivers and never had an error or problem.

When you uninstalled the graphic drivers normally, before driver sweeper, you might have removed more than just the graphic driver, like the chipset drivers.

So what happened now? From what I can tell, you have the old drivers back, it's back to normal, but you can't download or run the SC2 updater? What does the error say?
__________________


3770K | ASUS STRIX GTX 1080 | DDR3-1600 16GB | CORSAIR 650D | CORSAIR HX 850W | CORSAIR H100 | SOUND BLASTER Z | ASROCK EXTREME4 GEN3

b1gapl is offline  
Old 08-07-2010, 06:38 PM   #9 (permalink)
Newb Techie
 
Join Date: May 2010
Posts: 25
Default Re: A few questions about my system

I reinstalled SC2 and it's working now. The drivers are working fine as far as I can tell now.

I just noticed something odd though, in driver sweeper it shows NVIDIA chipset, NVIDIA display, and NVIDIA physX. Should I still be using those if I have an ATI graphics card? (I upgraded from an NVidia Card to an ATI a few months ago) Not really sure what those are exactly.
Musketman007 is offline  
Old 08-07-2010, 06:42 PM   #10 (permalink)
Mod Emeritus
 
b1gapl's Avatar
 
Join Date: Nov 2004
Location: USA
Posts: 13,044
Default Re: A few questions about my system

Those are just options if you did have an Nvidia graphic card. Since you have an ATi card, no you don't need to go through them. Just the ones associated with ATi.
__________________

__________________


3770K | ASUS STRIX GTX 1080 | DDR3-1600 16GB | CORSAIR 650D | CORSAIR HX 850W | CORSAIR H100 | SOUND BLASTER Z | ASROCK EXTREME4 GEN3

b1gapl is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Minimum System Requirements Questions Siena1383 Monitors, Printers and Peripherals 6 02-03-2010 05:18 PM
Please analyze my logs myr707 HijackThis Logs (finished) 6 06-23-2009 12:29 AM
gaming system custom build questions Cheeseking25 New Systems | Building and Buying 21 09-15-2007 12:35 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.