Bought some parts to upgrade my PC and now my monitor is blank. - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 11-26-2009, 04:34 PM   #1 (permalink)
Junior Techie
 
Join Date: Nov 2009
Posts: 42
Question Bought some parts to upgrade my PC and now my monitor is blank.

recently bought a new mobo, vid card, cpu, fan, and ram to upgrade my computer. I installed everything , switched it on and got a blank screen on my monitor. I have checked everything I can check and it works out fine. The monitor works with other computers and everything else seems to be powering up correctly but I still get nothing but a blank screen when i turn it on. My mobo has integrated video and I also bought a graphics card, and I get the same thing with each. I thought it might be a faulty mobo or I zapped it so I sent it back, got a replacement and the same thing is happining. I also bought another mobo thinking it might just be that and I am still haveing the same problems. As far as I know everything is compatible with each other and there is enough power getting to everything to power everything up, however I have begun to suspect that it might be my CPU. I had just the CPU, fan, ram, and speakers plugged in (also had the monitor plugged directly into the mobo) and I tried to run it then, hoping to get anything on the screen. Still nothing. It remains blank (like if the power was off) the entire time. Also, I am not getting any beeps from it either. So does that mean that something is wrong with the CPU? I have checked the connections on everything more times then I can count so I know everything is plugged in the way it is supposed to be. I even tried unplugging the RAM to see if I could get an error beep or anything, and still nothing, so I'm at a loss here. I'm going to list my specs below, any insites anyone has that can help would be greatly appreciated.

PSU: 460W

MOBO: Biostar MCP6P-M2 (website: Biostar MCP6P-M2 - motherboard - micro ATX - GeForce 6150 - Socket AM2)

CPU: AMD Athlon 64 X2 5000+ Socket AM2

Video Car: GeForce 9500 GT

RAM: 2G DDR 2 667 MHz
__________________

psycopuppy is offline  
Old 11-26-2009, 04:55 PM   #2 (permalink)
Lord Techie
 
Hefemeister's Avatar
 
Join Date: Feb 2004
Location: Sweden
Posts: 9,093
Default Re: Bought some parts to upgrade my PC and now my monitor is blank.

Your board has onbord graphics. Have you tried connecting the monitor to that connection? Many times you need to go into bios and change it from onboard to pci-e graphics before your card will output.
__________________

__________________
ASUS P6T Deluxe V2 :: INTEL i7 920 @3.4 :: XFX GTX260 :: 6gb Corsair 1600 :: Corsair 750TX :: TRUE 120 :: Samsung T240 24" :: Windows 7 X64

I do not accept support questions via PM

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
Hefemeister is offline  
Old 11-26-2009, 06:15 PM   #3 (permalink)
Junior Techie
 
Join Date: Nov 2009
Posts: 42
Default Re: Bought some parts to upgrade my PC and now my monitor is blank.

yes I have tried connecting the monitor to both the onboard graphics card and the external graphics card. I still get nothing. I dont even get to go into BIOS. When I press the power button I get nothing on the monitor. I dont get BIOS. I dont get a loading screen. I dont even get a flicker. The monitor is blank. and yes it is turned on and yes I have checked to make sure it works on other computers. it does
psycopuppy is offline  
Old 11-26-2009, 06:27 PM   #4 (permalink)
Lord Techie
 
Hefemeister's Avatar
 
Join Date: Feb 2004
Location: Sweden
Posts: 9,093
Default Re: Bought some parts to upgrade my PC and now my monitor is blank.

I would strip it down. Only cpu and ram. pull the vid card and go onboard. no hard drives or cd drives and just the 24 pin and 4 pin psu connectors into the board.

If you can get into bios then add the vid card back with the pci-e power connector into it and try again.

Have you checked your risers to ensure they are installed correctly and you do not have a random one grounding out your board from underneath?
__________________
ASUS P6T Deluxe V2 :: INTEL i7 920 @3.4 :: XFX GTX260 :: 6gb Corsair 1600 :: Corsair 750TX :: TRUE 120 :: Samsung T240 24" :: Windows 7 X64

I do not accept support questions via PM

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
Hefemeister is offline  
Old 11-26-2009, 06:51 PM   #5 (permalink)
Junior Techie
 
Join Date: Nov 2009
Posts: 42
Default

I have tried that. I have also tried moving the mobo outside of the case and onto a cardboard box incase there was a short. still nothing. I cant get into BIOS at all

sorry about the bitter tone btw, its just frusterating. I have been working on this problem for quite a while now and I have made almost no headway. And its not like I can go out and buy some new equipment either. So I'm not trying to be bitter to anyone at this point, I really appreciate whatever help u all can give me, and plz ignore any testiness u may sense from me. :P
psycopuppy is offline  
Old 11-27-2009, 05:19 AM   #6 (permalink)
Lord Techie
 
Hefemeister's Avatar
 
Join Date: Feb 2004
Location: Sweden
Posts: 9,093
Default Re: Bought some parts to upgrade my PC and now my monitor is blank.

Next I would try a different psu if available or test yours with a multimeter.
__________________
ASUS P6T Deluxe V2 :: INTEL i7 920 @3.4 :: XFX GTX260 :: 6gb Corsair 1600 :: Corsair 750TX :: TRUE 120 :: Samsung T240 24" :: Windows 7 X64

I do not accept support questions via PM

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
Hefemeister is offline  
Old 11-27-2009, 10:17 AM   #7 (permalink)
Junior Techie
 
Join Date: Nov 2009
Posts: 42
Default Re: Bought some parts to upgrade my PC and now my monitor is blank.

thats not an option, I dont have the money for that. and I checked the basic requirments and it needs less then what I have so I dont think it is that.
psycopuppy is offline  
Old 11-27-2009, 10:20 AM   #8 (permalink)
Lord Techie
 
Hefemeister's Avatar
 
Join Date: Feb 2004
Location: Sweden
Posts: 9,093
Default Re: Bought some parts to upgrade my PC and now my monitor is blank.

My concern is that the psu is bad not underpowered. Since you have swapped boards and it does not beep with the removal of ram that leaves us with cpu or psu.

so you have another system you can plug the psu into to check if you do not have a multimeter? Perhaps hook up your old board.
__________________
ASUS P6T Deluxe V2 :: INTEL i7 920 @3.4 :: XFX GTX260 :: 6gb Corsair 1600 :: Corsair 750TX :: TRUE 120 :: Samsung T240 24" :: Windows 7 X64

I do not accept support questions via PM

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
Hefemeister is offline  
Old 11-27-2009, 10:47 AM   #9 (permalink)
Junior Techie
 
Join Date: Nov 2009
Posts: 42
Default Re: Bought some parts to upgrade my PC and now my monitor is blank.

if it was the psu wouldnt the board have problems powering up? also, I am having the same problems with the old board. I havent done all the different things I have done to the new board (pulled ram, checked sound beeps, etc) but I still get the end result
psycopuppy is offline  
Old 11-27-2009, 11:45 AM   #10 (permalink)
Monster Techie
 
Brinson's Avatar
 
Join Date: Apr 2007
Posts: 1,195
Default Re: Bought some parts to upgrade my PC and now my monitor is blank.

This happened to my machine when I had the wrong voltage 4 pin molex attatched to the motherboard.
__________________

__________________
Antec 300 Illusion
430w Antec Earthwatts
AMD Q4 640 Propus
2x4gb Patriot DDR3 1333
750gb Seagate 7200.11 Hard Drive
Brinson is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.