Any one else having Trouble upgrading GPU?? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Thread Tools Display Modes
Old 10-08-2015, 05:32 AM   #1 (permalink)
Newb Techie
Join Date: Oct 2015
Location: united kingdom
Posts: 2
Default Any one else having Trouble upgrading GPU??

Hi currently in the midst of upgrading eveything in my computer but hit a few problems and am wondering if anyone else has expierenced something similar.

I recently bought a new gpu: XFX R9 380 4gb but when I plug it in and attempt to boot up my computer screen stays blank. but the fans on the card turn on and this is a replacement card so I'm sure there's no fualt with it.
When I try to boot up with the same cables only with my older gpu a Radeon HD 6800 series the computer boots up and everything works fine.

I have tried the other video ports
updating Bios
resetting Bios by removing the motherboard battery for 2 min
removing all the old drivers
updating all the drivers
making sure the bios settings are all appropiate e.g. secure boot disabled etc etc...
made sure my PSU is working (just upgraded, it can handle 1300W) so no power issues

The only thing I can think of is that it might be that my motherboard just can't recognise it for some reason? I plan to upgrade my mobo to this soon: Asus Z97 Pro Wifi-AC Motherboard (Intel Z97, USB 3.0, Socket 1150) but atm my mother board is the old : xps 8300 dh67m01 tb0420

my system information is
OS Name Microsoft Windows 7 Home Premium
Version 6.1.7601 Service Pack 1 Build 7601
Other OS Description Not Available
OS Manufacturer Microsoft Corporation

System Manufacturer Dell Inc.
System Model XPS 8300
System Type x64-based PC
Processor Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz, 3401 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date Dell Inc. A06, 17/10/2011
SMBIOS Version 2.6
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume2

Hardware Abstraction Layer Version = "6.1.7601.17514"

Time Zone GMT Daylight Time
Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 7.98 GB
Available Physical Memory 5.21 GB
Total Virtual Memory 16.0 GB
Available Virtual Memory 11.3 GB
Page File Space 7.98 GB
Page File C:\pagefile.sys

Any advice would be appreciated

reconvoid is offline   Reply With Quote
Old 10-08-2015, 06:07 AM   #2 (permalink)
The Almighty Forensica
Yami's Avatar
Join Date: Dec 2008
Location: UK
Posts: 7,438
Default Re: Any one else having Trouble upgrading GPU??

Make sure that the required PCI-E power cable(s) are plugged in. They're the ones at the bottom of this webpage:
All about the various PC power supply cables and connectors

Desktop i5-4440 - ASRock Z77 Extreme4 - EVGA GTX970 - 4x4GB 1600MHz - Samsung 850 EVO 250GB - Be Silent Base 800 - 3TB+1TB+640GB
Laptop i7-3740QM @ 2.7GHz, 2x4GB 1600Mhz, GT640M, OCZ Agility 3 120GB
Smartphone HTC One M8 - Sense 7 - 6.0

Uni MSci Ethical Hacking, Coventry University
Work Trainee Cell Site Analyst
LinkedIn Kiera Mitchell
Yami is offline   Reply With Quote
Old 10-08-2015, 06:29 AM   #3 (permalink)
Newb Techie
Join Date: Oct 2015
Location: united kingdom
Posts: 2
Default Re: Any one else having Trouble upgrading GPU??

oh yes all the apporpiate power cables are pluged in correctly
reconvoid is offline   Reply With Quote
Old 10-08-2015, 07:05 AM   #4 (permalink)
Build Guru
PP Mguire's Avatar
Join Date: Dec 2004
Location: DFW Texas
Posts: 26,047
Default Re: Any one else having Trouble upgrading GPU??

2 things. The motherboard being Dell might be bios locked for your old GPU, and your PSU isn't beefy enough.
"Resolution is just a number." #Ubisoft Origin/Steam = PP_Mguire Twitch = pp_mguire Instagram = ppmguire Mechwarrior Online = Thunderson PSN = PP_Mguire

Need Descent and Mechwarrior buddies!
If I helped you, give a thanks! ↓
Access to my Plex PM me.
PP Mguire is online now   Reply With Quote

boot, gpu upgrade, issue

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Any one else having trouble having getting work? Burn Folding @ Home 5 06-14-2010 08:49 PM
[AUST] TPG Users... Any one else having problems viewing thier account usage? Harper Computer Networking and Internet Hardware 0 07-29-2009 08:21 PM
Having trouble, trouble shooting O.o sirusx69 Hardware Repairs and Troubleshooting 14 10-28-2007 09:59 PM
Has any one else noticed...... AND_YOU_ARE New Systems | Building and Buying 15 12-01-2005 05:46 AM
did any one else get a pm? AND_YOU_ARE Off Topic Discussion 18 04-07-2005 08:24 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:50 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.