Another ram question. - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > System Upgrades
Closed Thread
Thread Tools Display Modes
Old 09-16-2005, 11:07 PM   #11 (permalink)
Lord Techie
Join Date: Jan 2005
Posts: 8,013
Send a message via AIM to DJ-CHRIS

Originally posted by ZeroStrife49
If my mobo has Dual Channel Technology, and in the 1st and 3rd slots i have Rosewill brand RAM, and if i put Corsair or some other brand in the 2nd and 4th slots, will my comp function properly? ive heard somewhere that u need same-brand ram in ur PC for it to run correctly.
Should run fine, but sometimes devil problems pop up, but this is rare.

I call it devil problems because 4 sticks of ram not working in a PC has no reason why it wont work, but it just doesnt work and their's no explination.

DJ-CHRIS is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:49 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.