OCZ tech support - Techist - Tech Forum

Go Back   Techist - Tech Forum > Member's Area > Off Topic Discussion
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 12-21-2005, 10:55 PM   #1 (permalink)
Banned
 
Join Date: Dec 2005
Location: in the past
Posts: 1,144
Send a message via AIM to thebleakness
Default OCZ tech support

As you might know, my ocz powerstream 520W is dead and i have to RMA it. Ive sent the tech guys there an email and they sent me back alittle questionaire about the product. It said that i shoud wait minimum of 24hrs for the actuall RMA number. Its been almost 48hrs. Have any of you here delt with OCZs tech support? is this normal? Should i email them again or would that screw with the process? I just dont know, i would like this psu soon but i dont want to make any more difficulties. Thanks for the advice.
__________________

__________________
thebleakness is offline  
Old 12-21-2005, 11:02 PM   #2 (permalink)
Wizard Techie
 
Dave's Avatar
 
Join Date: Mar 2002
Location: "Almost Heaven" USA
Posts: 4,866
Send a message via AIM to Dave Send a message via Yahoo to Dave
Default

Your first contact was probably via their contact page...is that correct? Now you have an email from them that you can reply to unless they said not to. If you can reply, then definitely send them an email. Also, make sure that their reply to you did not go into any SPAM folders.

If you have to use the contact form, then you might get someone that is different from the last person and re-start the process.

I'd think that you should contact them if you're sure that it's been over the allotted time for the RMA to come in.

Dave
__________________

__________________
Dave is offline  
Old 12-21-2005, 11:11 PM   #3 (permalink)
Banned
 
Join Date: Dec 2005
Location: in the past
Posts: 1,144
Send a message via AIM to thebleakness
Default

I actually called the tech support line and then the guy i talked to sent me the first email. I filled out the form and sent it back. Its the email of the techie that i spoke too, not their general email. Should i send the same form back filled out? or just ask for the condition of the RMA number?
__________________
thebleakness is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:27 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.