Who's amazing with Samba? - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Software > Linux and Open Source
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 01-19-2008, 05:51 PM   #11 (permalink)
Master Techie
 
Join Date: Apr 2004
Posts: 2,538
Default Re: Who's amazing with Samba?

ya, if you stop it then start it again its the same as a restart

samba reads its configure file once at startup and thats it, in order to force it to read it again and make the changes it has to be stopped and started again
__________________

horndude is offline  
Old 01-19-2008, 06:14 PM   #12 (permalink)
Wizard Techie
 
Join Date: Sep 2005
Location: /home/jason
Posts: 3,056
Send a message via AIM to Jayce
Default Re: Who's amazing with Samba?

Everything is set up, but 1 minor problem.

Here are my paths.

[jason]
path = /home/jason
writeable = yes
browseable = yes

[curt]
path = /media/driveb/curt
writeable = yes
browseable = yes

[tyler]
path = /media/driveb/tyler
writeable = yes
browseable = yes

[mom]
path = /media/driveb/mom
writeable = yes
browseable = yes

The issue is, any user who logs in can see all of the available paths. However, each user can click on any path they want. Granted, that's not a big deal in a home environment and all... but I have my path there (I'm Jason) because I want to be able to route everything to my laptop if I wish. However, MY MOM CAN GET INTO MY HOME FOLDER. Which is where my pictures are.

That's uh... a bad thing.

How can I restrict it so Tyler can only get in Tyler's folder, Mom can only get in Mom's, etc....?




Also, I want sdb2 to auto-mount to /media/driveb every time I boot up to Linux. How can I do that? By looking at my fstab file, all I see is that my NTFS partition of my first drive is commented out to not auto-mount.

Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda3
UUID=93094159-28b6-4ba2-9a34-c32639b00a05 /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda4
UUID=06b0f767-698d-4269-87c6-e87a46404bb5 /home           ext3    defaults        0       2
# /dev/sda1
#UUID=603865E23865B824 /media/sda1     ntfs    defaults,umask=007,gid=46 0       1
# /dev/sda2
UUID=9397ac6b-b51b-433e-8857-bf765234cd6c none            swap    sw              0       0
/dev/hda        /media/cdrom0   udf,iso9660 user,noauto,exec 0       0
/dev/hdb        /media/cdrom1   udf,iso9660 user,noauto,exec 0       0
__________________

__________________
There's no place like /home.
Jayce is offline  
Old 01-19-2008, 06:21 PM   #13 (permalink)
Master Techie
 
Join Date: Apr 2004
Posts: 2,538
Default Re: Who's amazing with Samba?

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
; comment = Network Logon Service
; path = /home/samba/netlogon
; guest ok = yes
; writable = no
; share modes = no

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;[profiles]
; comment = Users profiles
; path = /home/samba/profiles
; guest ok = no
; browseable = no
; create mask = 0600
; directory mask = 0700

ya, you have to create profiles for the users and setup samba as its own domain controller, I have never done this before so I'm not sure how this works, but the above is what you have to deal with, you also have to set up the domains section, no clue what the tricks are to that, can't be too hard though, it doesn't look like it is
horndude is offline  
Old 01-19-2008, 06:27 PM   #14 (permalink)
Master Techie
 
Join Date: Apr 2004
Posts: 2,538
Default Re: Who's amazing with Samba?

Quote:
Originally Posted by Jayce View Post




Also, I want sdb2 to auto-mount to /media/driveb every time I boot up to Linux. How can I do that? By looking at my fstab file, all I see is that my NTFS partition of my first drive is commented out to not auto-mount.

Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda3
UUID=93094159-28b6-4ba2-9a34-c32639b00a05 /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda4
UUID=06b0f767-698d-4269-87c6-e87a46404bb5 /home           ext3    defaults        0       2
# /dev/sda1
#UUID=603865E23865B824 /media/sda1     ntfs    defaults,umask=007,gid=46 0       1
# /dev/sda2
UUID=9397ac6b-b51b-433e-8857-bf765234cd6c none            swap    sw              0       0
/dev/hda        /media/cdrom0   udf,iso9660 user,noauto,exec 0       0
/dev/hdb        /media/cdrom1   udf,iso9660 user,noauto,exec 0       0
last line, change "noauto" to "auto"
__________________

horndude is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Amazing football play!!! H4x3r Off Topic Discussion 4 11-12-2007 10:29 PM
Amazing Deal Psu+ram NosBoost300 New Systems | Building and Buying 11 09-09-2007 09:29 PM
Samba + Windows + Me = Pure **** Dragonegger2 Computer Networking and Internet Hardware 7 07-27-2007 12:51 PM
New Amazing Call of Duty 4 Info Oreo Off Topic Discussion 23 07-08-2007 10:17 PM
6 Amazing Free Online Games Osiris PC Gaming 0 06-28-2007 08:28 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:35 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.