Decent Mobo on Newegg - Techist - Tech Forum

Go Back   Techist - Tech Forum > Member's Area > Buy/Sell/Trade and Hot Deals
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 05-25-2007, 12:44 PM   #1 (permalink)
Techie Beyond Description
 
veg1992's Avatar
 
Join Date: Dec 2006
Posts: 19,993
Default Decent Mobo on Newegg

Newegg.com - ECS NF650iSLIT-A (V1.0) LGA 775 NVIDIA nForce 650i SLI ATX Intel Motherboard - Retail
__________________

__________________
veg1992 is offline  
Old 05-25-2007, 07:33 PM   #2 (permalink)
j12
Monster Techie
 
j12's Avatar
 
Join Date: Jun 2006
Posts: 1,133
Default Re: Decent Mobo on Newegg

I wouldn't buy it just because its ECS. I would say 3/4 of their motherboards will have something crap out on you after a month or so. I have had 4 ecs motherbaords (they came in a combo deal) and 3 of them had problems. Usb ports stopped working, sata ports stopped working...etc. I only have 1 ecs mobo right now that is working completely fine.
__________________

__________________

Laptop:
MacBook 2.2GHz Santa Rosa | 120GB HDD | 4GB ram
Desktop:
Intel C2D E6300 @ 3.2GHz | 4GB ram | 880GB total HDD space | Gigabyte P965-DS3 | eVGA 8800GTS 640mb | Corsair HX 520 | Audigy 2 ZS platnium | Antec 900
j12 is offline  
Old 05-25-2007, 07:48 PM   #3 (permalink)
Retired.
 
peterhuang913's Avatar
 
Join Date: Dec 2005
Location: .
Posts: 8,076
Default Re: Decent Mobo on Newegg

im the lucky 25%
__________________
peterhuang913 is offline  
Old 05-25-2007, 09:00 PM   #4 (permalink)
Techie Beyond Description
 
veg1992's Avatar
 
Join Date: Dec 2006
Posts: 19,993
Default Re: Decent Mobo on Newegg

Quote:
Originally Posted by peterhuang913 View Post
im the lucky 25%
lol as am I, its awesome budget board, i believe i payed 40$ for one and it was
an NForce4 based but really good!! anybody else had XP'riences with these mobos?
__________________
veg1992 is offline  
Old 05-26-2007, 01:07 AM   #5 (permalink)
Wizard Techie
 
Join Date: Jul 2005
Posts: 3,453
Send a message via AIM to FghtinIrshNvrDi Send a message via Yahoo to FghtinIrshNvrDi
Default Re: Decent Mobo on Newegg

had an ECS. It didn't have the overclocking options I wanted, but is running fine in my friend's computer 2 years later.

Ryan
__________________

<b>I'm an unhyphenated American.</b>
System Specs:
Intel Q6600 @ 3200 1.4v
Abit IP35 Pro "The Snake"
2x2gb A-Data @ 800
Diamond HD 3870 512mb


Great FORD TRUCK resource: http://www.fordtruckfanatics.com
FghtinIrshNvrDi is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Plugging wires in the mobo power panel incorrectly piggysmile Hardware Repairs and Troubleshooting 2 05-25-2007 09:17 PM
What Power and Mobo? weee107 New Systems | Building and Buying 6 05-21-2007 11:22 AM
cannot install vista.. got a dell mobo siddanth3 New Systems | Building and Buying 13 04-30-2007 06:05 PM
mobo CPU fan changing tone smurph Hardware Repairs and Troubleshooting 4 04-20-2007 07:06 AM
MoBo question xcoreRelentless New Systems | Building and Buying 1 04-07-2007 10:55 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:55 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.