PC wont accept my new GPU - Techist - Tech Forum

Go Back   Techist - Tech Forum > Techist Forum Information > New Member Introductions
Thread Tools Display Modes
Old 06-25-2014, 08:54 PM   #1 (permalink)
Virgin Techie
Join Date: Jun 2014
Location: Ireland
Posts: 0
Question PC wont accept my new GPU

I have a problem with my pc for a while now
It is that i bought a new GPU the AMD R9 290 and i currently have 2 GTX GT 545 and when i tried replacing it the screen was black and it said no signal what is the problem here? by the way my pc is and Alienware Aurora i bought in 2011
Any help would be greatly appreciated

My specs are:Operating System
Windows 7 Home Premium 64-bit SP1
Intel Core i5 2400 @ 3.10GHz 52 C
Sandy Bridge 32nm Technology
6.00GB Dual-Channel DDR3 @ 665MHz (9-9-9-25)

Alienware 046MHW (CPU 1)

S240HL (1920x1080@60Hz)
DELL ST2320L (1920x1080@60Hz)
1023MB NVIDIA GeForce GT 545 (NVIDIA)

465GB Seagate ST3500413AS (SATA)

Optical Drives
MagicISO Virtual DVD-ROM0000

Realtek High Definition Audio

Power supply

hiitsrabbit is offline   Reply With Quote
Old 06-25-2014, 09:50 PM   #2 (permalink)
Monster Techie
Drogos's Avatar
Join Date: Apr 2007
Posts: 1,346
Default Re: PC wont accept my new GPU

this is a stupid question but im going to ask it. did you plug both PCI-E power plugs into the card most newer cards take 2 plugs instead of 1.

AsRock z97x,i5 4690k@ 4.4ghz, Custom Water Loop, Nvidia 980TI 6GB, Corsair Dominators Platinum 16GB 2666mhz ,250 SSD,2TB,2TB Drive ,EVGA Supernova 750G2 PSU,NZXT H440 white. Asus 24" 144hz, LG 42" led lcd.
Drogos is offline   Reply With Quote
Old 06-25-2014, 10:03 PM   #3 (permalink)
Virgin Techie
Join Date: Jun 2014
Location: Ireland
Posts: 0
Default Re: PC wont accept my new GPU

Yes i did
hiitsrabbit is offline   Reply With Quote
Old 06-25-2014, 10:18 PM   #4 (permalink)
Monster Techie
acerinpa's Avatar
Join Date: Jan 2009
Location: USA
Posts: 1,649
Default Re: PC wont accept my new GPU

Did you delete/uninstall all the old Nvidia drivers and download/install the Catalyst suite and the proper AMD drivers for the 290?

Also did you put the new card in the first PCI slot on the MOBO - just in case as you were using 2 GPU's before.
acerinpa is offline   Reply With Quote

alienware, amd, blackscreen, gpu, hardware

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Plz accept my apology... beedubaya Off Topic Discussion 21 04-15-2005 12:05 PM
Why do my MSI K7N2 Delta2 doesn't accept pc2100 or 2700ddr ram EricB Monitors, Printers and Peripherals 5 12-19-2004 06:42 PM
BIOS doesn't accept settings! TheMajor Overclocking and Modding 4 08-18-2004 09:12 PM
Force network to accept all connections? piranha_jawz Computer Networking and Internet Hardware 2 07-31-2004 03:37 PM
To Accept Majority Accessibility or Not? Trickster Programming 4 04-04-2003 04:43 AM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:33 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.