late.... - Techist - Tech Forum

Go Back   Techist - Tech Forum > Techist Forum Information > New Member Introductions
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 12-07-2004, 03:19 AM   #1 (permalink)
Monster Techie
 
Join Date: Dec 2004
Posts: 1,291
Default late....

its a little late but hello 2 all

ZImon
__________________

__________________
Simon is offline  
Old 12-07-2004, 03:29 AM   #2 (permalink)
Monster Techie
 
willsko87's Avatar
 
Join Date: Apr 2004
Location: Melbourne, Australia
Posts: 1,240
Default

lol...just slightly
__________________

__________________
http://www.aflonline.com.au



willsko87 is offline  
Old 12-07-2004, 03:38 AM   #3 (permalink)
Super Techie
 
Join Date: Dec 2004
Posts: 365
Default

Welcome to TF im new aswell
__________________
Elite Bullet is offline  
Old 12-07-2004, 05:58 AM   #4 (permalink)
PowerQuest / Opera
 
TheMajor's Avatar
 
Join Date: Jun 2004
Location: Netherlands
Posts: 10,177
Default

Welcome!
__________________
TheMajorMMX - Intel P200 MMX @ 225Mhz - V-Tech (PcPartner) Baby-AT mb w/ Intel Triton TX chipset - Nvidia Riva TNT2 M64 w/ 16MB - 256MB M-Tec SDRAM - Still running.....
TheMajor is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:39 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.