HI ya! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Techist Forum Information > New Member Introductions
Closed Thread
Thread Tools Display Modes
Old 11-18-2003, 11:47 AM   #1 (permalink)
True Techie
Join Date: Nov 2003
Posts: 185
Cool HI ya!

I have been posting for awhile but never here. So I thought I would do this now. I'm 29, been in love with comps since they first came out. Just recently started to make enough money to buy and play with them. Now I build them for friends and family. I will always be learning more about them though I am sure. So If I ask stupid questions, forgive me.
Attached Images
File Type: gif untitled-12.gif (49.7 KB, 11 views)
dfi nfII ultr infinity/asus p4s800
amd 2500xp m/p4 2.6
ati 9600/ati 9600 pro
512mb pc3200/512mb pc3200
trebor is offline  
Closed Thread

« Me | hi!!! »
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:45 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.