Hello again - Techist - Tech Forum

Go Back   Techist - Tech Forum > Techist Forum Information > New Member Introductions
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 09-03-2015, 12:12 AM   #1 (permalink)
Wizard Techie
 
Join Date: Jan 2003
Location: US
Posts: 3,313
Default Hello again

It's been literal years since I've been here. I'm impressed the site is still around! I just wanted to say hello.
__________________

__________________
You could say I've been around.
Shakie
Shakie is offline   Reply With Quote
Old 09-03-2015, 12:19 AM   #2 (permalink)
Banned
 
Join Date: Jul 2015
Location: Enid Oklahoma
Posts: 331
Default Re: Hello again

Hi Yup the site is still around and it's getting better all the time.
I'm a newbie here. I'm sure you have old friends here that will be very happy to see you again.
I've been around also, but I'm thinking about staying here. Some real good and smart people here that know what's going down! So far they are tolerating me. I'm hoping that will continues!! LOL
Gary
__________________

donetao is offline   Reply With Quote
Old 09-03-2015, 07:22 AM   #3 (permalink)
Grandfather of Techist

\_(ツ)_/
 
Trotter's Avatar
 
Join Date: Jan 2005
Location: The South
Posts: 31,301
Default Re: Hello again

Quote:
Originally Posted by Shakie View Post
It's been literal years since I've been here. I'm impressed the site is still around! I just wanted to say hello.
Ghosts do exist! Great to see you around, Shakie. It has definitely been a minute or two. How has life been treating you?

I don't get as far north as you are. I cover stores in Hartsville and Lafayette but the Nashville stores are pretty much centralized.
__________________


My Rig: SABLE
Antec 300 Illusion / Antec EarthWatts EA650 650W / ASUS GeForce GTX 960 GTX960-DC2OC-2GD5
AMD FX 8320 x8 Black Edition / Gelid Tranquillo / MSI 970A-G43
Sandisk Ultra Plus 128GB / Samsung 840 120GB / WD Black 750GB / WD Green 1TB
2x4GB DDR3 1600 - 2x2GB DDR3 1600
Win10 Ent 64-bit - Mionix Naos 7000 Mouse - CM Storm QuickFire Rapid Mech Keyboard


R.I.P. Danny L. Trotter ... 14 Nov 1945 - 4 Sept 2009
Trotter is online now   Reply With Quote
Old 09-03-2015, 10:07 AM   #4 (permalink)
Banned
 
Join Date: Jul 2015
Location: Enid Oklahoma
Posts: 331
Default Re: Hello again

I thought I posted this before! I guess if it was deleted, it will get deleted again. Maybe I forgot to submit it.
What brings you back to Techist after being away for a long time?? Getting ready for a merger with CF. It might help the owners to know why you're back. I'm always trying to help even though it's none of my business. I'm a newbie here. I really like both forums and it will be interesting to see how they get along after the merger!
Gary!!
donetao is offline   Reply With Quote
Old 09-03-2015, 01:20 PM   #5 (permalink)

Triforcer
 
Baez's Avatar
 
Join Date: Sep 2005
Location: Toronto, Canada
Posts: 6,987
Default Re: Hello again

Well look who it is! Welcome back my friend.

There's still a few of us long-timers around.
__________________


Baez is offline   Reply With Quote
Old 09-03-2015, 03:02 PM   #6 (permalink)
Wizard Techie
 
Join Date: Jan 2003
Location: US
Posts: 3,313
Default Re: Hello again

@Totter: Hey man! It's been a while right. Life got busy and complicated so I had to focus elsewhere. As I've aged, I've figured out that I don't have to worry about every little thing (mainly my kids - they're teenagers now). Nashville is nice, but like any 'bigger' city, it's got it's ugly too.

@doneato: I got a HBD email from 'techist' and had no idea what that was, so I figured I'd figure out what was going on. (I didn't realize the name changed from 'tech-forums')

@Baez: Yeah man, noticing that. Thanks for the welcome back!
__________________
You could say I've been around.
Shakie
Shakie is offline   Reply With Quote
Old 09-07-2015, 08:48 AM   #7 (permalink)
Lady Techie
 
Yami's Avatar
 
Join Date: Dec 2008
Location: UK
Posts: 7,772
Default Re: Hello again

Hi! I don't remember you so you're probably from before my time :P
__________________

__________________
Desktop i5-4440 - ASRock Z77 Extreme4 - EVGA GTX970 - 4x4GB 1600MHz - Samsung 850 EVO 250GB - Be Silent Base 800 - 3TB+1TB+1TB+640GB
Laptop i7-3740QM @ 2.7GHz, 2x4GB 1600Mhz, GT640M, OCZ Agility 3 120GB
Smartphone Galaxy S7 Edge

LinkedIn Kiera Mitchell
Yami is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blue Screen again and again nabelnajib Hardware Repairs and Troubleshooting 0 12-08-2011 08:48 AM
I'm tired - online spam again and again... :( pharmacyst1282 System Upgrades 1 10-16-2006 07:58 AM
Hello again new rig questions again libotte New Systems | Building and Buying 8 07-22-2006 02:39 PM
changed my mind again, and again... chevytrucknut New Systems | Building and Buying 5 12-06-2005 06:51 AM
"new cpu detected" again & again & again... jz10 Monitors, Printers and Peripherals 2 12-03-2004 06:18 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:04 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.