Hello - Techist - Tech Forum

Go Back   Techist - Tech Forum > Techist Forum Information > New Member Introductions
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 09-18-2014, 04:58 PM   #1 (permalink)
True Techie
 
Join Date: Sep 2014
Location: USA
Posts: 114
Default Hello

Hi all,

been reading through a lot of forum posts the last few days and i've been pretty happy with how open and helpful this forums members seem to be. Thought it might be time to join up and see if i can lend a hand anywhere, and of course get some free advice myself.

the1truegamer
__________________

the1truegamer is offline   Reply With Quote
Old 09-18-2014, 06:07 PM   #2 (permalink)
Grandfather of Techist

\_(ツ)_/
 
Trotter's Avatar
 
Join Date: Jan 2005
Location: The South
Posts: 31,307
Default Re: Hello

I'm glad you made it back. I must confess that I nuked the wrong account the other day. >_<
__________________

__________________


My Rig: SABLE
Antec 300 Illusion / Antec EarthWatts EA650 650W / ASUS GeForce GTX 960 GTX960-DC2OC-2GD5
AMD FX 8320 x8 Black Edition / Gelid Tranquillo / MSI 970A-G43
Sandisk Ultra Plus 128GB / Samsung 840 120GB / WD Black 750GB / WD Green 1TB
2x4GB DDR3 1600 - 2x2GB DDR3 1600
Win10 Ent 64-bit - Mionix Naos 7000 Mouse - CM Storm QuickFire Rapid Mech Keyboard


R.I.P. Danny L. Trotter ... 14 Nov 1945 - 4 Sept 2009
Trotter is offline   Reply With Quote
Old 09-18-2014, 06:23 PM   #3 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,508
Default Re: Hello

Shame on you Trotter!

Sent from my Nexus 7 using Tapatalk
__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline   Reply With Quote
Old 09-18-2014, 06:24 PM   #4 (permalink)
True Techie
 
Join Date: Sep 2014
Location: USA
Posts: 114
Default Re: Hello

Ahh, well thanks for taking care of me. I just gave it a day and then checked to see if my user name existed. I guessed maybe something like that happened. I actually fat fingered my username the first time and had to change my email address etc to reapply...problem located behind keyboard. Thanks for getting me back in though.
the1truegamer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hello, hello... Venom8151 New Member Introductions 4 11-17-2008 03:54 PM
Hello, hello - Handshakes all around Jougukny New Member Introductions 21 10-29-2007 11:15 PM
Hello, hello jon krause New Member Introductions 6 11-14-2004 07:08 PM
hello hello ctracer New Member Introductions 3 07-14-2004 09:07 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.