PSU works fine, but I can't jump start my watercooling loop... - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Overclocking and Modding > Cooling
Closed Thread
Thread Tools Display Modes
Old 03-13-2012, 09:31 AM   #11 (permalink)
Super Techie
Join Date: Sep 2010
Posts: 345
Default Re: PSU works fine, but I can't jump start my watercooling loop...

Originally Posted by Sean W. View Post
lol thats too funny!

when i put the water block on my 5870, got it on made sure it was 100% on properly, put in the computer, plumbed it, got all the air bubbles out, went to turn the compute ron for the first time, a horrific screech came out of the computer, scared the crap out of me and i unplugged my computer thinking i just fried my $1800 computer... freak out, get on my server computer, and make a thread explaining in detail of what i did and what happened. someone simply said:

" plug the graphics card in "

*looks down at the computer * forgot to plug the pci express power cables into the card to power it up...

plugged it in, powerd up just fine, overclocked the snot out of it = profit
Great minds think alike!

Case: Cooler Master HAF X RC-942-KKN1
Power Supply: Silverstone ST1500 1500W
Motherboard: Asus Rampage IV Extreme; CPU: i7-3970; Memory: Corsair Dominator Platinum 32GB @ 2133MHz
Graphics Card: HD7970
Optical: 2 x Lite-On iHAS424SATA 24X DVD
Hard Drive: OCZ RevoDrive 3 X 2 240 GB
Monitor: Samsung 1080P 120Hz 3D
earwicker7 is offline  
Old 03-13-2012, 09:59 AM   #12 (permalink)
patonb's Avatar
Join Date: Jan 2005
Location: In Gov't Regulated Cubical
Posts: 9,737
Default Re: PSU works fine, but I can't jump start my watercooling loop...

Damn modular psu's playing tricks on you!

Foldie = i7 950@ 4.0Ghz Gigabyte x58a-ud3r EVGA 970 SC Corsair H100 Corsair hx520 3x2gb OCZ Gold Corsair 650D
Woohoo = L5639 @3.1Ghz EVGA SR-2 gtx 260-216 Hyper 212+ Corsair 1050hx 6x2gb Corsair XMS3 Blackhawk Ulra
Alienware 18 - SLI 770M 4700mq 16Gig

patonb is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Watercooling masters help me with loop! Guttzu New Systems | Building and Buying 1 05-26-2011 07:31 PM
watercooling loop... ordering soon!!! NosBoost300 Overclocking and Modding 72 06-27-2008 12:12 AM
Watercooling loop rite? RyanWhitell Overclocking and Modding 5 11-25-2007 04:00 PM
Watercooling Loop Help RyanWhitell New Systems | Building and Buying 7 11-22-2007 07:24 PM
HDD stops pc from starting up, works fine under different PSU Vindye Monitors, Printers and Peripherals 3 03-09-2005 05:50 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:51 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.