Replacing my Pump - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Overclocking and Modding
Closed Thread
Thread Tools Display Modes
Old 12-06-2006, 12:29 PM   #11 (permalink)
The Water Cooling Guru
aspire's Avatar
Join Date: Feb 2005
Location: United States
Posts: 5,308

Id take off the old ones and replace them with the worm drive clamps. The link was just to show what they were...

If I help you with something, you think I'm the bomb, or you just like what I said, rep me by clicking the star under my post.


The Official Tech Forums Water Cooling Informational Guide
aspire is offline  
Old 12-06-2006, 09:17 PM   #12 (permalink)
Master Techie
reggie_da_man's Avatar
Join Date: Feb 2005
Posts: 2,567

The only thing is I'm not %100 sure if they'll stay on. The connector is a little weirdly shaped, whatever I'll see. Thanks.


reggie_da_man is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:20 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.